Mint 17.2 Won't Boot After Install

After the installation of Mint 17.2, computer won't boot at all. Come to screen saying "insert media / device"

Toshiba c55d - B5241
Secure boot - - OFF

All the basics have been done, don't insult my intelligence.

I changed the boot sequence to the HDD and disabled everything else. Still no help
Tried mounting the sda2 (which is my ext4)

Uhm, whenever i try to install grub2 to that partition, it says "probe failed, installing i386"
Afterwards, it just says some BS about /cow.

Tried reinstalling (not sarcastically), about 12 times. No avail. Tried 2 different DVDs, all my usb drives, and even an SD card. Nothing works.

Tried updating (sudo update whatever), multiple failures.

Right now i'm booted into Mint Live on the usb, trying to work the partitions. NO avail. Currently, based off of the basic mint install (not side by side, complete wipe of the hard drive) here is a list of my partitions:

sda 1 fat32 512 mb
sda 2 ext4 ~500GB
SDA3 LINUX-SWAP 3.44 gb
1 mb of unallocated space.

Pretty much about done with this, will go to win7 if this isn't solved, and won't look back at linux / ubuntu.

I've tried for years to get ubuntu to proper install on a multitude of systems and it's never worked. So, if this "community" has the ability to help me and change me over to a better operating system, y'all might have my support in the the future.

1 Like

Congratulations, Mint, you fucking bricked my laptop.

Not trying to insult your intelligence - but did you check the MD5 hash of your install ISO?

Boot from live USB, run gparted and wipe the entire HDD. The whole thing formatted as ext4. Just one giant partition.

Reboot

Boot live USB

Install Mint, let it figure out the partitions itself

Shut down laptop after install, remove USB an dthen power back on.

If it will not boot, type exactly what it shows on screen. Dont panic if it seems like nothing is happenning at first, first boot after install can be slow as hell

Looks like my BIOS is corrupted now, trying to solve that first. Extreme fragmentation at BIOS and unable to select things. Also, 5 beeps at start up now.

5 beeps is a POST fail, unplug everything, remove the hdd, then power up the laptop and see if it boots to POST

laptop is apart, taking out cmos and other stuff. Will get back in about 15 minutes

1 Like

Alright, laptop is back together, and installed new bios. Used gparted to wipe everything. Waiting for installation.

update Everything is installed, rebooted, removed USB, pressed enter. Screen now says "reboot and select proper Boot device
or Insert Boot Media in selected boot device and press a Key

reinserted USB

In terminal please post output of

sudo fdisk -l

also

sudo blkid

i think the problem is installing grub to /dev/sda2, your /root partition? You need to install it to the device name not the partition, ie /dev/sda not a number.

boot with your live media,

sudo grub-install --boot-directory=/mnt/boot /dev/sda
sudo update-grub2

2 Likes

One sec, wife needs me to do something.

okay

[email protected] ~ $ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 1 976773167 488386583+ ee GPT

Disk /dev/sdb: 2003 MB, 2003828736 bytes
62 heads, 62 sectors/track, 1018 cylinders, total 3913728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009e87d

This doesn't look like a partition table
Probably you selected the wrong device.

Device Boot Start End Blocks Id System
/dev/sdb1 ? 3223366752 3470046675 123339962 f4 SpeedStor
/dev/sdb2 ? 378192737 710426324 166116794 10 OPUS
/dev/sdb3 ? 225603442 225603451 5 74 Unknown

Partition table entries are not in disk order
[email protected] ~ $ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/sdb: LABEL="UUI" UUID="2ADA-6E99" TYPE="vfat"
/dev/sda2: UUID="6ad2ac5c-2562-450d-8507-f4f7f7fd89db" TYPE="ext4"
/dev/sda1: UUID="9519-F060" TYPE="vfat"
/dev/sda3: UUID="07e5f253-b388-4c76-b9f7-e233da4091f3" TYPE="swap"
[email protected] ~ $

That's the first part

Second part here:

[email protected] ~ $ sudo grub-install --boot-directory=/mnt/boot /dev/sda
grub-probe: error: failed to get canonical path of /cow'.
Installing for i386-pc platform.
grub-install.real: error: failed to get canonical path of
/cow'.
min[email protected] ~ $ sudo update-grub2
/usr/sbin/grub-probe: error: failed to get canonical path of `/cow'.

opps that was me being a retard.

you need to
sudo chroot /mnt

then

sudo grub-install --boot-directory=/boot /dev/sda
sudo update-grub2

might be easier to re install then all this faffing about, just remember on the partition screen to choose the root of the boot disk ie /dev/sd[x] not /dev/sd[x]1

You're missing a partition to support your EFI booting (assumption based on it being a win8.1 laptop)

Here's what my boot drive looks like:

/dev/sdb1     2048  1050623  1048576  512M EFI System << GPT partition type 1
/dev/sdb2  1050624 62529535 61478912 29.3G Linux filesystem

EFI partition != Boot partition

Even with secure boot disabled, you are still using EFI

Is this Mint LMDE or the main edition? Make sure your using an installer that detects UEFI and just let it sort it out for you first time round.

If you end up on legacy boot and GPT partitions you'll need a "BIOS Boot" partition

Make sure fast boot is disabled too

1 Like

Okay,

So, yes, win 8.1 machine. I've tried reinstalling, Linux doesn't know how to install stuff. I'm using the main edition.

Fastboot is disabled.

I'll manually create a boot partition and see what that does.

The partition you need /boot/efi as fat32 file system. If you don't do that you will need to turn on legacy/BIOS booting like @Buckshee said.

Allllrighty, so I added a biosgrub partition and an EFI partition. One of them's gotta work

I don't understand why you need to use GParted, I thought Mint main edition used the Ubuntu installer and that's got quite adequate partitioning support.

I used the installer to make my partitions, I deleted the older partitions using GParted previously just to make sure everything on the hard drive was completely gone.

ok, that made me see some other details in your notes, what's the 2Gb thing on /dev/sdb? and why is your root partition on it?

That's how Mint decided to make it on its own. wait wait

Disk /dev/sdb: 2003 MB, 2003828736 bytes
62 heads, 62 sectors/track, 1018 cylinders, total 3913728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009e87d

That? That should by my USB drive ...maybe

UPDATE! Still not working. Even with efi partition built

Wow! I figured out how to fix it! I figured out the secret of Linux!

1 Like