Minecraft does not work on Wayland

For those who are using Arch Linux (or any other distro that has wayland), Minecraft will not work when using Wayland as your display server. It will work using Xorg without any issues, just don't try using it with Wayland.

I tried tons of different "fixes" but all of them are from years ago and the file hierarchy doesn't even match what the "tutorials" or "help sites" specify.

Just a warning to all trying to use Minecraft on Linux

I have it working fine on wayland. There are some graphical glitches on the loader but once you start the game it works fine.

I'm surprised because I literally haven't been able to get it working at all. Always got the same error which was the following:

-- System Details --
Minecraft Version: 1.8.8
Operating System: Linux (amd64) version 4.2.5-1-ARCH
Java Version: 1.8.0_66, Oracle Corporation
Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 52964352 bytes (50 MB) / 90177536 bytes (86 MB) up to 954728448 bytes (910 MB)
JVM Flags: 1 total; -Xmx1G
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
Launched Version: 1.8.8
LWJGL: 2.9.3
OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
Is Modded: Probably not. Jar signature remains and client brand is untouched.
Type: Client (map_client.txt)
Resource Packs: []
Current Language: ~~ERROR~~ NullPointerException: null
Profiler Position: N/A (disabled)
Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
Anisotropic Filtering: Off (1)

The moment I switched back to the Xorg server (by choosing GNOME), I was golden. There must be some setting that I'm missing or just not using the right search terms. Anything special that you did?

Sorry, I just noticed I'm on Xorg. This computer is a mess, dont even know how it is even running anymore, really needs a clean install.

Are you running it through xwayland?

I'm not sure. I had it installed with gnome if I'm not mistaken. Either way, when I select it in the menu of display servers I have GNOME, GNOME classic and then Wayland. Written just as such.

When using Wayland you can only use x applications through xwayland. If it wasn't built with Wayland support it won't work natively. I think programs are supposed to use xwayland automatically but it might be a Java limitation.