Return to Level1Techs.com

Microphone not working WRX80E-SAGE SE WIFI

Hey guys,

So, like the title says, just got and put together my Threadripper Pro setup, installed Ubuntu 20.04 on it. Everything works great except picking up the microphone audio input. There is sound from headphones and the system does seem to detect the microphone but still, all I get is sporadic static from arecord -f cd - | aplay -.

inxi -Fxz says:

System:    Kernel: 5.11.0-40-generic x86_64 bits: 64 compiler: N/A Desktop: Gnome 3.36.9 
           Distro: Ubuntu 20.04.3 LTS (Focal Fossa) 
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter> 
           Mobo: ASUSTeK model: Pro WS WRX80E-SAGE SE WIFI v: Rev 1.xx serial: <filter> UEFI: American Megatrends v: 0602 
           date: 07/13/2021 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3 charge: 100% (should be ignored) 
           status: Discharging 
CPU:       Topology: 32-Core (4-Die) model: AMD Ryzen Threadripper PRO 3975WX s bits: 64 type: MT MCP MCM arch: Zen 
           L2 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 447185 
           Speed: 2196 MHz min/max: 2200/3500 MHz Core speeds (MHz): 1: 1917 2: 2303 3: 2194 4: 2196 5: 2192 6: 2195 7: 2195 
           8: 2193 9: 2195 10: 2194 11: 2197 12: 2195 13: 2195 14: 2398 15: 1919 16: 1920 17: 1918 18: 2196 19: 2195 20: 2195 
           21: 2191 22: 2193 23: 2194 24: 2195 25: 2195 26: 2196 27: 2200 28: 2196 29: 1953 30: 1916 31: 2195 32: 2194 
           33: 2194 34: 2195 35: 2199 36: 2195 37: 2185 38: 2394 39: 1918 40: 2194 41: 2195 42: 2195 43: 2197 44: 2194 
           45: 2178 46: 2195 47: 2202 48: 2192 49: 2197 50: 2376 51: 1916 52: 1913 53: 2195 54: 2195 55: 2192 56: 2195 
           57: 2194 58: 2195 59: 2190 60: 2195 61: 2196 62: 2195 63: 1916 64: 1916 
Graphics:  Device-1: ASPEED Graphics Family driver: ast v: kernel bus ID: 29:00.0 
           Device-2: NVIDIA vendor: ASUSTeK driver: nvidia v: 470.82.00 bus ID: 2e:00.0 
           Display: x11 server: X.Org 1.20.11 driver: none resolution: 3440x1440~60Hz, 1920x1080~60Hz, 2560x1440~144Hz 
           OpenGL: renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2 v: 4.6.0 NVIDIA 470.82.00 direct render: Yes 
Audio:     Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 2e:00.1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: N/A bus ID: 30:00.4 
           Device-3: ASUSTek USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 5-6:3 
           Sound Server: ALSA v: k5.11.0-40-generic 
Network:   Device-1: Intel Ethernet 10G X550T vendor: ASUSTeK driver: ixgbe v: kernel port: N/A bus ID: 24:00.0 
           IF: enp36s0f0 state: down mac: <filter> 
           Device-2: Intel Ethernet 10G X550T vendor: ASUSTeK driver: ixgbe v: kernel port: N/A bus ID: 24:00.1 
           IF: enp36s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 25:00.0 
           IF: wlp37s0 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
           IF-ID-2: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A 
Drives:    Local Storage: total: 1.82 TiB used: 130.85 GiB (7.0%) 
           ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP600 size: 1.82 TiB 
Partition: ID-1: / size: 1.05 TiB used: 130.82 GiB (12.2%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 53.8 C mobo: 33.0 C gpu: nvidia temp: 60 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 fan-7: 0 gpu: nvidia fan: 97% 
Info:      Processes: 848 Uptime: 1h 55m Memory: 125.63 GiB used: 38.43 GiB (30.6%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38 

I’ve tried the usual stuff, tinkering with alsamixer, pavucontrol but nothing seems to work. The system is a dual boot and the mic works fine on Windows side so I know it’s not busted.

Appreciate any help or advice