Microphone is staticky mess, no matter what I do

My microphone is unusable in Linux, despite the hours of troubleshooting I’ve tried, from all sorts of guides all over the place. I know it’s a software issue in Linux, as the microphone works perfectly on my Windows 10 dual boot. I also tried booting into a live CD of Ubuntu 18.10, and got the same staticky crap.

The relevant specs:

OS: Arch Linux
CPU: AMD Ryzen 2700X
Motherboard: MSI X370 Xpower Gaming Titanium (https://www.msi.com/Motherboard/X370-XPOWER-GAMING-TITANIUM/Specification), which has a Realtek ALC 1220 audio controller.
Microphone: Antlion ModMic 5. It’s just a regular mic that attaches to a headset, connected via the aux in on my case. No special drivers needed.

I’ve tried all the troubleshooting methods in the Arch Wiki, in both the PulseAudio and ALSA sections, and in other places, but nothing has worked.

If anyone here has any insight it would be greatly appreciated.


what application are you using to test the microphone? I had an issue with discord where it was giving a lot of static and I had to turn off the accelerated graphics mode.

Have you tried taking a wire around the connector and putting it to ground?

Maybe windows filters it out some how, while it might just be ‘raw’ input in the linux machine.

Its a problem with pulseaudio and some scheduling and/or timing. I made notes about the fix at home as I’ve ran into the problem twice. The fix has been reliable but it seems to be a little different per system.

Its something to do with the tsched config and snd-hda-intel module.

Here is the article that I used to help identify the issue. I’ll have to post later after referencing my notes on how I fixed it.


Edit - Updated link to the proper section.

@jdfthetech: Iv’e tried Gnome Sound Recorder, Discord, Audacity and arecord. All the same.

@Cutie Pretty: sure there’s no way I can jam a wire into my aux port without damaging something. I’ve looked in the Windows config for the microphone to see if I could find some settings that could give me more info, but found nothing. I’m 99% certain its a software issue.

SudoSaibot: I’ve already tried the troubleshooting steps you’ve linked.

This is what I have written down for the fix.

In /etc/pulse/default.pa
load-module module-udev-detect
load-module module-udev-detect tsched=0

In /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=MODEL position_fix=3

I took a thin metal wire, and put it in a small loop, then plugged the cable into the pc, and used my chassi as a ground point, as my headphones had a lot of static. it fixed it for me. Sadly i didnt have the issue under linux, but htis was more of a general hope it would help .><

@SudoSaibot: Yeah I’ve tried this, but it didn’t work. As I said, I’ve gone through everything in the Arch Wiki, and everything else I could find online.

@Cutie: Thanks for the help anyway.

@99lives Have you found a fix now? I’ve had the same issues with no fix so far. Running Manjaro XFCE

Nope, I’ve had this issue ever since I built the PC almost 2 years ago, and I’ve pretty much given up.

I just got my Thinkpad T495 with the same codec ALC 1220 and i have the same issue … sadly no solutions and I excluded pulseaudio being the culprit :frowning:

What kernel are you using? Does the static go away when the computer is just using battery power? Does the static get worse while doing something cpu/gpu intensive?

I wonder if it’s a circuitry issue, as cutie was alluding to.

1 Like

I doubt it’s hardware - at least with my issue. I was able to make the crackling much more subtle … but it’s still here.

https://rush.sh/Cl_RUYwF76ngvbIB5l5aBzmYY08/test.wav <- check out this recording and the “click” in the brackground.

The steps I’ve taken yesterday with a lot of trial and error:
options snd-hda-intel power_save=0 model=clevo-p950

I think power_save=0 helped the most … and clevo was just something I found randomly on the Internet. I can post a recording later of how it was without these settings