Memory sticks showing up with half capacity: Epyc 7443P + Asrock Rack ROMED4ID-2T:

I am dealing with a very weird situation:

I put in a new Epyc 7443P CPU into a new Asrock Rack mini ITX motherboard.
Board is running BIOS 3.00 and BMC 01.00.00, the only ones available on Asrock rack website.
I have populated all 4 slots with the Micron 64 GB MTA36ASF8G72PZ-3G2E1VI memory, which is on Asrocks Memory QLV list (Picture of the memory module attached).

I found out that one of the sticks is dead (hence one slot appears empty). While troubleshooting it, I realized that all of the memory sticks are showing up as 32GB ?!?

I tried re-seating them couple of times, and as expected, it didnt help.

How do I explain and troubleshootthis?

How is it possible that all 3 sticks show up, but only with half capacity?

Is it some motherboard option I need to enable?

Is there a chance someone swapped stickers and these are actually some random 32GB dimms?

How can i verify the RAM model number from bios or IPMI interface? Asrock’s IPMI is pretty bad as usual, the inventory doesnt show anything, its totally empty


Three DIMMs is not a supported memory configuration. Try with just two DIMMs in C1 and D1 and see if they are recognized correctly.

issue still present with just 2 sticks in the board on C1 and D1 slot. One stick - also same thing

The sticker in the photo you posted looks pretty pristine. I would think it would be difficult to swap stickers without leaving a wrinkle, smudge, some slight crookedness on at least one of the modules… but I guess it’s possible.

You should be able to read the module’s SPD values with the free version of Memtest86. After it boots to the GUI navigate to System Info → View detailed RAM (SPD) info. Should hopefully have a model number listed.

hello
this is not by any mean an eplanation to what is going on on your system.
(i am assuming you have tried every combination possible: 1 stick, nope as per the manual 2 sticks 4 sticks, and swaping the sticks around)
(i am also assuming your cpu and its socket are fine _ no suspicious pin)
I tried to look for the QLV (to double check compatibility) but did not find it… ?

After checking a few things i went to the ftp server and found this:

ftp> ls ROMED4ID*
200 Port command successful
150 Opening data channel for directory listing of "/BIOS/SERVER/ROMED4ID*"
-r--r--r-- 1 ftp ftp       27049340 Apr 15  2021 ROMED4ID-2T(01.00.00)BMC.zip
-r--r--r-- 1 ftp ftp       10812813 Aug 18  2021 ROMED4ID-2T(3.00)ROM.zip
-r--r--r-- 1 ftp ftp        6190344 Mar 03  2021 ROMED4ID-2T(3.00)WIN.zip
-r--r--r-- 1 ftp ftp       10812487 Mar 25  2021 ROMED4ID-2T(L0.11)BMC.zip
-r--r--r-- 1 ftp ftp       10934826 Mar 22 16:19 ROMED4ID-2T(L3.16)ROM.zip

on the .cn ftp server

if you feel … adventurous, you could try updating :stuck_out_tongue:

the file date seem to indicate there is an update to the bios…
Although tbh this does not seem to be a bios revision problem/solution.

to go towards your question i would direct you to a linux bootcd to use some dmi magic:
sudo dmidecode --type 17
this should give you the part number from the module’s POV (to check the conformity of the sticker)

EDIT: typos, formating