Memory Problems

Hi there, 

I have the flowing Components

  • Corsair 650D
  • AsRock 990FX Extreme 3 Motherboard
  • AMD FX8350 @ 4 GHZ (Corsair H110 Pull Config)
  • Kingston HyperX Beast 4 X 4gb 2400hz @ (Currently 647hz) 
  • Corsair AX760 80Plus Platinum PSU
  • AMD R9 290
  • Samsung 840 Pro 256 SSD
  • WD Black 1TB

the issue is that i have tried setting up the timings on the motherboard manually but end up getting a failed boot. The exact Serial of the memory is KHX24C11T3K4/16X 

i do believe there should be no issue with the compatibility but possibly something stupid that i have done in setting them up.


Any help will be appreciated



oh and there is a picture on my profile if you care to look.

It may just be your FX8350. Not all of them have a memory controller capable of running 2400mhz ram.

That is a clean looking PC.  How many other frequencys have you tried and at what timings? Subtimings might need to be raised a little as well, sometimes auto doesn't seem to do the job the higher you go.

Thanks jon666 i have successfully managed to get it to 1333hz but i think it might have been a fluke. i will post the CPU-Z screen share 

photo CPUZcapturememory_zpsbb5d5343.png

Lame, looks like you are running close to JEDEC. Not sure why it reads 647mhz it should be close to 667.

Okay I cheated and looked this up lol. Never had an AMD build so I suggest you take a look.