Memory dump problem

I just built a pc for gaming it works great most of the time but everyday I play a game for an hour or so it freezes and says memory dump error and restarts I am extremely worried I am hoping there is an easy fix to this problem so I can enjoy my games without worrying about this annoying/upsetting problem.


OS-windows 7 ultimate 64bit

GPU-Sapphire vapor x 7950

CPU-Fx 8350

Ram-corsair vengence 8gb (2x4gb)

Motherboard- Asus m5a97 le r2.0

Heatsink- coolermaster hyper 212 evo


I am running the latest drivers even the beta for my 7950 is that the problem? also my heatsink is pushing on one of the ram sticks it doesnt seem to be a problem but anything is possible..


Test your ram with memtest86 allso if your heatsink is pushing a stick it may not be seated correctly 

It happens randomly I was playing tomb raider this time for an hour or so and it popped up but earlier I was playing battlefield 3 for 2 hours and it didnt crash its really random. I ran McAfee and did a full scan and it showed no viruses or anything and then I ran Windows memory diagnostic and it showed no problems. I find it odd but really upsetting.

Oh sorry after doing research about memtest86 im supposed to burn a disk sorry for the misunderstanding.

Yes it's a iso but you can boot it from a usb stick.

Okay so should I try the memtest first and then if it says no problems should I redo my heatsink? Also if I remove the heatsink do I have to reapply thermal paste or should it be fine?

boot memtest up and let it run for 20-30mins than you will have to look at outher options if it says your ram is good

No problems it said I let it go for 30 minutes...

I also did like 50 windows updates would that have fixed the problem?


Just in case anyone else has this problem all I had to do was download CCleaner and clean my registry and the blue screen has never appeared ive played more than 7 hours straight on battlefield 3 I hope this helps someone.

ouch... ccleaner registry cleaner is a bad idea. I fucked up my windows when I used that.....

and your supposed to use memtest86+, the windows tester is terrible


What registry cleaner do you suggest? that was the only one I had and it fixed the problem easily I havent had a problem yet maybe im just lucky and had an odd problem it said I had allot of corrupted files probably because I transfered files from my laptop to a usb to my new computer.