Manjaro update to login screen is black SOLVED

Had an update to my Manjaro, and when I rebooted the login screen is black, I can still type in password and hit enter and get to the desktop.
Was wondering if anyone else had this problem?
Is there a fix for this problem?
Did a shot of screenfetch for the info.

(Nvidia related?)

Proprietary drivers don't act well on bleeding edge distros, expect all kinds of breakage

1 Could I install the nouveau drivers and not use the proprietary one?
2 Do the nouveau drivers work well in older games ( my newest game running is Boarderlands 2 )?

I will take more stable and lose 5fps and use the nouveau drivers vs using proprietary and have more problems.

form the Terminal ps -ef | grep dm

You might need to reinstall your Display manager.

Nouveau drivers are compiled in the kernel, they work by default but the performance is horrible.
If you have an nvidia card you'd want the proprietary drivers and a stable distro.
However if you install the lts kernel plus the nvidia-lts drivers from manjaros repos you should be golden for the most part.

What will the command do, still learning the commands

When I checked the drivers after OS install the nouveau drivers where running, In the Manjaro setting manager, I switched to the nvidia driver , It is just marked nvidia-driver

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=ec2174cc-ea93-4f04-9abe-172a48891322"
should look like this after I am done
GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 quiet splash resume=UUID=ec2174cc-ea93-4f04-9abe-172a48891322"

Then in the command line I type this to take effect.
$ sudo grub-mkconfig -o /boot/grub/grub.cfg

the file was labled grub

its a bit noobish but you can install nouveau and then get back into your desktop. Then use the GUI driver manager to install the closed source afterwards.. its either that or spend a while on the terminal.

if its any consolation i just had to fix Ubuntu Gnome when installing the beta 370 nvidia drivers, screwed up my plymouth for some reason.

I have the nvidia propriatery drivers installed, just used the GUI in manjaro.

Trying to fix the black login screen.

light DM GTK+ is the greeter setting manager

Sorry i got my wires crossed, bit tired what is the login manager ?

I assume reinstallation or a different manager will work

Login manager is Light DM GTK+
I reinstalled LightDM GTK + and the LightDM GTKsetting from the package manager
went in and selected a different theme restarted and still the same black screen.

I thought you had an issue with the Display Manager which is why you were not seeing the logon screen. The ps -ef | grep dm is to see if your DM is there, because if you cant see the logon screen then you could reinstall it...

Or you could just role back to the previous kernel.

This is a pic of the info from the command

I have been thinking about rolling back the kernel, but was hoping to us this as a learning tool and see what I can do before rolling back the kernel.
And the problem is not really that bad to roll back the kernel as of yet.

Going to install and have an older kernel ready just in case the problem get bigger.
Was hoping to hear back from @Baz and his suggestion to fix the problem.

I was going to recommend [actually edited] installing the video driver and commands to blacklist and reconfigure grub... But I honestly have a gut feeling that removing LDM and reinstalling it will solve the issue... You can do this from the Terminal in runlevel 3 then log back into the desktop

If you could give a point by point discription I will give it a try.

The screen shot I took is that showing the right info say that everything is working.

I'd be glad to help. There are a couple questions:

Did you install the Proprietary drivers from the Terminal? How did you did you install them? Repo update?


Installed OS on a 80gb hard drive partions /boot 200mb linux swap 2gb /root 20gb and the rest /home. It is a small root partion will make it bigger when I format my ssd after moving windows to a HD
Checked to see what drivers where running using the GUI they where the nouveau drivers.
Using the GUI I uninstalled the nouveau drivers and installed the nvidia-driver.
Everything was working then I got an update to and there was an nvidia driver update as well to 367.36.02. I did this update using the terminal and the command
sudo pacman -Syyu
I watched the install and there was no errors.
If you need more info I will try my best to remember what I did.

1 Like