Return to Level1Techs.com

Manjaro - system lag when opening new programs or whilst running games

Hey all. I’ve got this strange issue I’m hoping I can get resolved. I have 3700x, Gigabyte Aeorus Elite x570 MB, Gigabyte 2070 Super graphics card, 32 GB 3600 Mhz RAM. Using the propriatary driver (440.100) on Manjaro. Kernel 5.7. KDE Plasma.

Whenever I open up a new program or do anything “new”, the system lags momentarily. For example, if I’m watching a Youtube video and I open up Gimp, the video lags a little while the song sounds choppy for half a second. While I’m playing a game (I play a lot of WoW), and I’ve got spotify running in the background playing music, the game will lag a bit during song skips. I’ve got dual monitors, both running at 60 Hz.

Other than this, the system is smooth and I’ve eliminated screen tearing as is a normal issue with Nvidia. Not using triple buffering or pipeline compositing. Also tried with these on, with no improvement. My CPU barely goes above 30% at any time and I’ve got at least 2/3 of the memory free too, so bottlenecking should definitely not be whats happening here.

I’d say I’m an intermediate Linux user. Any help would be greatly appreciated! Thanks.

To be honest I have no idea what is wrong with your setup. Just out of curiosity can you please try it out with a single monitor connected?
I had an issue that I would get artifacts and lags when using two monitors, but that was with the free drivers, and monitors connected to two different graphic cards.

I had a similar issue, although in gnome desktop on Ryzen 1600 / RX580, did you try changing to the LTS kernel? Currently 5.4.52-1 in Manjaro Settings Manager.

I would say to try the ZEN kernel if LTS doesn’t help and see if that helps at all.

Gonna try it tonight. Will report back.

I was running the LTS Kernel initially, and I’ve been having the same issue all along regardless of kernel version. I recently upgraded from 5.6 to 5.7 as 5.6 was becoming deprecated.

Zen Kernel? Can’t see that it’s available in the kernel manager. How would I go about trying it out?

Mmmmm…

I see on Manjaro it is probably easier to just try the Liquorix Kernel. It is available in the AUR:

https://aur.archlinux.org/packages/linux-lqx/

Reason I would say to try this is for the different scheduler. Might solve your problem.

Just make yourself familiar with what to do if your system doesn’t boot up. “Esc” to enter grub - choose old kernel and then boot.

Doesn’t seem to be related to the dual monitor setup. I disconnected one and the issue still persists. I turned off the desktop notification for Spotify when a new song plays (it would ordinarily be displayed behind the game, and cause the lag. When I disabled it, the lag on song skip disappeared. So I’m guessing it’s a compositor/Kwin issue. I just tried enabling triple buffering in the driver and in the kwin.sh file, and it seems better. Not perfect, but better.

My guess, it’s an Nvidia doesn’t play well with Linux issue. I wish I had a proper AMD card to test with, but unfortunately I don’t. Probably should have gone with the 5700XT instead of the 2070, but it’s a bit late to turn back now. The system is rock solid otherwise. I’d rather not mess around with the alternative kernel, but thanks for the tip anyway. If it drives me insane, I have another option to try. And if anyone else has any other tips, I’ll gladly try them.

Just wanted to post an update. Enabling Triple Buffering in kwin.sh along with the Xorg config pretty much solved everything for me. System is butter smooth now and I couldn’t be happier!