Manjaro Linux (or Antegros) and Brother network Printer

I have been running linux on various desktops and laptops for a bit (since starting the linux for a year challenge) and I love my debian variants (i.e. Ubuntu, xUbuntu, etc) but I still prefer the archlinux variants in particular Manjaro. But my biggest issue with Manjaro I have been unable to resolve... installing drivers for my networked Brother Laser Printer (MFC-7840W).

The Brother website has linux drivers / installation packages in both DEB and RPM packages, and the DEB packages work flawlessly on my Debian variants.

I have tried

  1. Installing the drivers for the Brother MFC-7840W from AUR with no success (i.e. que holds the print jobs and never releases them, or the system freezes.... tried on laptop and desktop pc)
  2. I have tried adding the printer through CUPS interface with no success (i.e. installs but print jobs just stay in the que never printing)
  3. I have even tried using the RPM extraction that some sites describe and using that to build the installation on Manjaro (this was a never ending build and installation nightmare that forced me to purge the Manjaro installation).

Any thoughts on a resolution?

I have a Brother printer as well. Mine is a different model, so this might not help (DCP-7010L). For some reason every now and again, the driver will pause the printer.. there is no evidence anywhere that it is paused. It is only when I suddenly remember that it does that sometimes, and I open up cups, and "resume" it that it begins actually printing... Maybe your printer is simply paused as well?

Best of luck!