Manjaro doesn't detect my second monitor until I reinsert HDMI cable

Hey guys, thanks for the help. For some reason my computer isn’t detecting my second monitor unless I reinsert the cable for it, then it works fine. It’s also worth mentioning that the system is quite laggy (types text on screen 3 seconds after I type it, choppy animations, slow button clicks, etc.) until I reinsert that cable, but after it works like it should. The monitors are plugged into different cards (the one that works is in a 1070, the one that’s buggy is in a Vega 56).

here is my inxi -Fxz
System:    Host: Manj-desk Kernel: 5.0.7-1-CUSTOM x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.3 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z370 Killer SLI/ac serial: <filter> UEFI: American Megatrends v: P1.20 
           date: 11/27/2017 
CPU:       Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88728 
           Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 801 10: 800 11: 800 12: 800 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] vendor: ASUSTeK driver: amdgpu 
           v: kernel bus ID: 03:00.0 
           Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: ZOTAC driver: nouveau v: kernel bus ID: 04:00.0 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu,nouveau FAILED: ati unloaded: modesetting 
           resolution: 1920x1080~60Hz, 2560x1440~60Hz 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.27.0 5.0.7-1-CUSTOM LLVM 8.0.0) v: 4.5 Mesa 19.0.1 
           direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel v: kernel 
           bus ID: 03:00.1 
           Device-3: NVIDIA GP104 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 04:00.1 
           Device-4: Kingston type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-2:3 
           Sound Server: ALSA v: k5.0.7-1-CUSTOM 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: d000 bus ID: 09:00.0 
           IF: wlp9s0 state: up mac: <filter> 
           Device-3: NetGear type: USB driver: mt76x2u bus ID: 4-1.3:4 
           IF: wlp6s0u1u3 state: down mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 15.38 GiB (1.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-00BN5A0 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB 
Partition: ID-1: / size: 227.94 GiB used: 15.38 GiB (6.7%) fs: ext4 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: nouveau temp: 43 C fan: 0 device: amdgpu temp: 38 C fan: 766 
Info:      Processes: 261 Uptime: 13m Memory: 15.66 GiB used: 1.35 GiB (8.6%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 5.0.2 inxi: 3.0.32
Here is xrandr --listproviders
Providers: number : 2
Provider 0: id: 0xad cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 5 associated providers: 1 name:Radeon RX Vega @ pci:0000:03:00.0
Provider 1: id: 0x68 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 4 outputs: 5 associated providers: 1 name:nouveau
Here is xrandr --listmonitors before reinsertion
Monitors: 1
 0: +*DP-1-3 2560/598x1440/336+0+0  DP-1-3
Here is xrandr --listmonitors after reinsertion
Monitors: 2
 0: +*DP-1-3 2560/598x1440/336+0+0  DP-1-3
 1: +HDMI-A-1 1920/256x1080/192+2560+0  HDMI-A-1

I had a similar problem with monitors using different resolutions.
Have you tried making their resolutions and refresh rate the same and seeing if the problem still occurs?
If that is indeed the case, then perhaps you could setup a script to flip them back after boot.

nope, just tried it and rebooted and the working monitor defaulted to its native 1440p resolution. Unplugged and replugged and the second monitor came on and both went to the resolution i set.

Are you using an adapter for HDMI?