Malfunctioning USB ports - Windows stuck at Bios splash screen

Quick rundown of what happened prior to the problems.
Asus X99a mobo.

Put an install of ubuntu gnome 15.1 on a usb to test out. On boot selected USB from bios as the boot device. Had a play with linux, all fine and dandy.

When I boot back into windows no problems.

The next day as i'm booting into windows it stays stuck at the splash screen, I press delete to get into bios and nothing happens. I see the keyboard and mouse backlights aren't on so i unplug them and plug them back in to the rear USB ports. Light's come on, nothing happens when i press any keys. Then when I try another port, lights come on and it boots into Windows 10.

I restart computer, try again and same issue, keyboard and mouse don't light up, when i unplug and plug the keyboard back in, it powers on but doesn't register the delete or F2 key presses to get into the bios. I restart again and at the post screen i unplug the keyboard as it's failing to light up into almost every other usb port available and still nothing happens. Windows then boots up after 20 seconds or so.

I tried again, keyboard stayed on, i got into the bios and made sure the boot drive was the one with my win10 install. The usb ports that were not powering on the keyboard the last time i got into windows are now working. It's still inconsistently powering on the keyboard/mouse when the machine posts.

Any idea what's going on here? Motherboard issue or Windows issue/ could running a live usb even mess with windows?

Thanks in advance guys

Try another power supply, otherwise get that RMA started

So you think this is a motherboard issue as opposed to a software issue? When i'm within windows it's all working as per normal, it's just the weird stuff happening on boot.

does the motherboard have like a physical bios switch or reset on it?

I will check and if it does i'll reset it, thanks i didn't think of that.

If this is it it definitely has some switches on it

also ya totally shoulda got the sabertooth man

You don't know how deep that cuts. I had the chance to buy a second hand sabertooth or the X99a and he decided to keep it at the last minute >.<

Wait you bought it used? Are you sure this isn't why he kept the sabertooth?

Nah the X99a is brand new. When i was getting all my parts together I found an awesome deal on a sabertooth board but after he pulled out I just bought a new board.

Shoulda just lived without a case for a while

did you read the manual about what the switches do?

Currently sifting through my box cupboard trying to find it. Found the online manual so i'll check it out now. Also I failed to mention the clock has also gone a bit haywire and it changed the time for some reason..?

If your time reset your CMOS battery may be dead or needs to be reseated, but that won't affect much besides your clock

Don't even bother

I have the exact same mobo with the exact same issues.

I would also be willing to bet that if you tried to overclock your CPU that you would not be able to push it very far.

A very select few asus x99 users have been running into issues like this.

And just to recap, I have tried different PSUs, different ram, video cards, and hard drives.

It is either a bad cpu (which is unlikely) or bad mobo.

I personally am going to rma this board, and then test it to make sure everything is kosher and then sell this fucker for cheap.

I will turn around and buy the matx ws board.

Sorry if i'm being thick here but is resetting CMOS the same thing? The only button the X99a has is the bios flashback on the I/O shield.

the CMOS battery just keeps your clock alive

Ok update. I opened up the case and got the following from the mobo display led : 98: Console input devices connect followed by 9C:USB Detect and then AA:System has transitioned into ACPI mode. Interrupt controller is in APIC mode.

If i just let it do it's thing on a cold boot up with only the keyboard plugged in, it will hang with a code of 98 on the motherboard and then when it boots into windows everything is fine.

Still the same thing going on at boot. Still trying to figure out how to reset the bios.

Found a handy video from this tek channel i sometimes watch

When i have time tomorrow i'll just do this.

So i flash backed the bios and the issue is still happening. Peripherals stay powered off during the post screen, they turn on after the post screen, before the windows logo.

May have to RMA this one... drat.

Yeah, I got the same results.

Can you do me a favor and post your revision number?

If I can prove that there is just a bad revision, and report it to asus, then it will help a lot of people process these RMAs a LOT faster.

So i updated windows. Did the upgrade and everything, still issue with power on at post screen. PC working fine before everything completely froze. I had to pull the plug (I know... not much else I could do) and restart. I turned off fast boot, changed the boot priority again. Peripherals now power on at boot but aren't responsive, ie i press the del key and nothing happens for about 10-15 seconds, then it boots to bios.

Restarted again just to check, peripherals stayed off the entire time even when i booted into windows, then windows came up with an error message saying 'usb device not recognized'. Unplug both keyboard and mouse from their respective usb ports (they were in usb 3.0) and moved to usb 2.0 ports and they work.... So strange. Can't identify if it's a windows or mobo issue.

Where can i get the revision number angel? I checked the box but wasn't on any of the receipt or identifier stickers. I'm assuming it's located somewhere on the mobo?

Okay, I am not familiar with your board, but Asus boards have an option in the bios to turn off all USB devices during boot or all devices except for mouse and keyboard. also, are you certain your keyboard and mouse are plugged into the KBM USB sockets? I know mine dont work unless they are in those specific sockets.