Looping Login on Parrot OS & Realtek fails to update

For the last few days there has been a head-scratcher on not being able to login to ParrotOS.
The boot-up to the login screen is fine; but on password entry the login screen reappears. Any attempts to run updates is met with a failed realtek-trt18188eus-dkms error. Any suggestions would be appreciated, as currently this setup is dead in the water.

Text consoles work just fine BUT Login fails on normal boot, NVIDIA boot AND is fine on APCI boot

Please see reddit post with similar problem

What happened with your last upgrade. I am willing to bet that it bailed when it could not compile the DKMS module. What is the actual error here?

Also can you switch the display server from your greeter. If you have been using Wayland, try X or vice versa.

I am not familiar with Parrot but if it is APT based then do something like

apt -f install

or

dpkg --install --half-configured --half-installed

Thanks for the reply, the force install only had the same error. Please see a different reddit Post

The suggestion to purge the realtek-trt18188eus-dkms did allow apt install upgrade to run. There is an error saying Removing duplicate launchers…
[-] Invalid executable path nautilus at launcher /usr/share/applications/brasero-nautilus.dektop.

Going to reboot and try again.

Parrot is like kali but based on debian iirc

No, not fixed yet. If i boot to APCI i can open Brasero, but still I don’t know what is actually broken.

Because your handle makes me think that you are a fellow fighting game fan,

What happens when you do a apt -f install full-upgrade.
An upgrade is non-distructive and will not uninstall anything. A full-upgrade [dist-upgrade] will remove unneeded software and do software replacements and etc. Don’t do the actual upgrade but see what it is trying to remove and what it is trying to add as new.

Thanks. Then like Kali, aren’t you supposed to do full upgrades and not updates since they release it on the BSD model. Or is my age messing with me here?

Yes was a TO and its a ‘double entendre’ on Networking.

Thanks, I don’t know if that directly fixed anything; I can get past the realtec dkms now, but i still cannot login without getting kicked back to the login screen.
For future readers, I believe the ‘install’ is superfluous for the full upgrade.
It will only be apt -f full-upgrade – apt will not know what package full-upgrade is.

Wow, I am so dense. I did not notice that before. That is very clever!

My bad on that, I was distracted. Yes. the install command either takes no additional input or you supply a package name. My bad y’all.

Alright before I nuke and pave for the third time, it seems I will always find the error in some way. Reinstalling the OS does fix it however I am unable to finish a VMware install[won’t compile] and updating the Nvidia Drivers will cause the login screen problem to start again.
Sooooo…POP goes the weasel and try again later.

Is there a reason why you are using Parrot? Have you tried another distribution to see if if you get the same issue? I stick to the main distributions and I don’t really touch their children so I am not really familiar with what Parrot offers over other distributions that make it a must have.

**Edit
I know it is like Kali, but I don’t know of any sane person that runs that as a main environment.

Short answer is out of the box look and feel. This is only my 4th or 5th flavor, and I’m using pop for now, and I don’t love it. And using using the Parrot home works for me, and i would never run the security version as a daily driver either.
Either way the I will check back in to see if anything got fixed. VMware Workstation being broken on both pop and parrot is also FTSIMO.