Return to Level1Techs.com

Lookingglass Failed to create EGL surface

I have been using Lookingglass for a while on my gentoo system. I had a recent system update and broke lookingglass though I have no idea how. My virtual machine is running without issue, but when I launch lookingglass I get the following:

[I]               main.c:996  | run                            | Looking Glass (B1-rc6-6-gb979752989+1)
[I]               main.c:997  | run                            | Locking Method: Atomic
[I]                egl.c:187  | egl_initialize                 | Double buffering is on
[I]                egl.c:201  | egl_initialize                 | Multsampling enabled, max samples: 4
[I]               main.c:902  | try_renderer                   | Using Renderer: EGL
[I]               main.c:1183 | run                            | Using Clipboard: X11
[I]              spice.c:197  | spice_connect                  | Remote: 127.0.0.1:5900
[E]                egl.c:428  | egl_render_startup             | Failed to create EGL surface (eglError: 0x300b)
[I]               main.c:1259 | run                            | Waiting for host to signal it's ready...

The client exits back to the command line with no further information. The only argument I am passing is “-a”.

I have tried rebuilding the entire client but continue to get the issue. Can someone point me in the right direction. I’m sure it is something simple I am missing which changed with my most recent system update but I cannot figure it out for the life of me.

Thanks

drc

I bet you’re running a AMD GPU and have the amdgpu-pro packages installed? If so, amdgpu-pro doesn’t support OpenGL ES, you need to revert to the plain amdgpu packages.

Pretty certain that I am not. I did an “lsmod | grep amd” and saw this:

amd
amdgpu               3842048  47
kvm_amd                90112  18
kvm                   659456  1 kvm_amd
mfd_core               16384  1 amdgpu
gpu_sched              32768  1 amdgpu
ttm                    90112  1 amdgpu
drm_kms_helper        163840  1 amdgpu
drm                   397312  18 gpu_sched,drm_kms_helper,amdgpu,ttm
i2c_algo_bit           16384  2 igb,amdgpu

Any other thoughts?

Also, is gles what is needed? Not full gl? Maybe its missing somewhere else, like kwin or something (it is set to GL not GLES)

The open source amdgpu kernel module works with the amdgpu-pro packages and is actually the preferred usage. OpenGL ES is provided by the userspace libraries not the kernel module. The amdgpu-pro packages are completely missing ES support.

What distro are you running? You can check for the pro packages easily under Ubuntu/Debian by running dpkg -l | grep amdgpu

I am sorry I confused this with a similar error of 0x3008, I believe the issue you’re having has been addressed by a pull request that was made earlier this month. I have just verified it and merged it with the repository (https://github.com/gnif/LookingGlass/commit/70110b4a5aa2ef48bef0dc30340329bb27dcc332), can you please update and try again?

That seemed to do the trick :slight_smile:

Awesome, can you please then mark this thread as solved.

So marked. Thanks so much for your help.