Return to Level1Techs.com

Looking glass woes

Woes with KVM running on fedora @ Ryzen 5950x and RTX 3080.

Looking glass bleeding edge compiled on host and bleeding edge binary installed on win10 guest.

Service running on Win10 guest, when launching looking-glass-client from the linux host i get the following:

3071442232 [I] main.c:1029 | main | Looking Glass (B3-175-gedbd6f6ade)

3071442243 [I] main.c:1030 | main | Locking Method: Atomic 3071445678 [I] ivshmem.c:126 | ivshmemOpenDev | KVMFR Device : /dev/shm/looking-glass 3071454957 [I] egl.c:270 | egl_initialize | Double buffering is off 3071454963 [I] main.c:640 | tryRenderer | Using Renderer: EGL 3071458196 [I] gl.c:55 | waylandGetEGLDisplay | Using eglGetPlatformDisplay 3071469385 [E] egl.c:654 | egl_render_startup | Failed to create EGL surface (eglError: 0x3004)

With debug flags:

ype “apropos word” to search for commands related to “word”… Reading symbols from ./looking-glass-client… (gdb) set args -s -a -k -n (gdb) r Starting program: /home/delta/LookingGlass/client/build/looking-glass-client -s -a -k -n warning: Expected absolute pathname for libpthread in the inferior, but got .gnu_debugdata for /lib64/libpthread.so.0. warning: File “/usr/lib64/libthread_db-1.0.so” auto-loading has been declined by your `auto-load safe-path’ set to “$debugdir:$datadir/auto-load”. To enable execution of this file add add-auto-load-safe-path /usr/lib64/libthread_db-1.0.so line to your configuration file “/home/delta/.gdbinit”. To completely disable this security protection add set auto-load safe-path / line to your configuration file “/home/delta/.gdbinit”. For more information about this security protection see the “Auto-loading safe path” section in the GDB manual. E.g., run from the shell: info “(gdb)Auto-loading safe path” warning: Unable to find libthread_db matching inferior’s thread library, thread debugging will not be available. 2860960070 [I] main.c:1029 | main | Looking Glass (B3-175-gedbd6f6ade) 2860960097 [I] main.c:1030 | main | Locking Method: Atomic 2860997529 [I] ivshmem.c:126 | ivshmemOpenDev | KVMFR Device : /dev/shm/looking-glass 2861005887 [I] egl.c:270 | egl_initialize | Double buffering is off 2861005897 [I] main.c:640 | tryRenderer | Using Renderer: EGL [New LWP 11548] 2861010619 [I] gl.c:55 | waylandGetEGLDisplay | Using eglGetPlatformDisplay 2861041457 [E] egl.c:654 | egl_render_startup | Failed to create EGL surface (eglError: 0x3004) [LWP 11548 exited] [Inferior 1 (process 11544) exited with code 0377]

Link to config
pastebin: czHT8wUi

Any help please? im at my wits end :S

I assume the 3080 is the GPU you pass to the Windows guest. What is your host GPU (the one that runs on the Linux side)?

gtx 1060 6GB
VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1) (prog-if 00 [VGA controller])

Please properly format your post, nobody is going to spend the time trying to read an unfomatted dump.

Surround your pasted text in back-ticks, like so
```
text
```

2 Likes