Return to Level1Techs.com

Looking Glass - "Waiting for Host to Restart"

Since November I’ve been using a Virt-Manager/QEMO GPU-Passthrough setup.

I never had any issues with it, and now I would like to use looking glass to more easily record the output of the windows GPU.

I following Looking-Glass’ instructions on their website:

  1. Updated RAM Controller Driver on the Win10 VM

  2. Installed the latest release candidate on the Win10 VM

  3. Used CMAKE to build the client (of the same version) on my Linux Machine (Arch)

When I boot the VM and then execute “looking-glass-client” in the linux terminal, the purple window opens and the terminal output continues until it says “Waiting for Host to Restart”.

I tried rebooting the vm, restarting the service in services.msc, restarting the executable manually, but nothing works.

Also disabled my ufw on Arch completely and disabled the Scream-Audio Service on both machines, no luck.

Does anybody have a clue as to what could cause this?

In the VM, look at the hosts log.

Yes please post your host log here. You can find it in Windows in your user’s temp directory:
%TEMP%\looking-glass-host.txt
i.e.:
C:\Users\<username>\AppData\Local\Temp\looking-glass-host.txt

This is incorrect. In the latest builds the location has changed to:

C:\ProgramData\Looking Glass (host)\looking-glass-host.txt

Instead of giving path information, it’s always a good idea to ask the users to right-click the LG tray icon and click “Log File Location” for the proper path

1 Like

Thank you 2 @psyblade @Netboy3 for your messages, I only now had time to actually get to troubleshooting this.

Even though I use the (latest?) B3-rc1 Version, my config file was indeed stored in %TEMP%/looking-glass-host.txt

Looking through the logs, these failures / errors stick out to me:

   110589241 [E]          wrapper.cpp:60   | NvFBCInit                      | Failed to load NvFBC64.dll: 0x0000007e (The specified module could not be found.)
...
   110628960 [W]               dxgi.c:439  | dxgi_init                      | Failed to set realtime GPU priority.
   110629411 [I]               dxgi.c:440  | dxgi_init                      | This is not a failure, please do not report this as an issue.
   110629937 [I]               dxgi.c:441  | dxgi_init                      | To fix this, install and run the Looking Glass host as a service.
...
   111534576 [E]                app.c:272  | captureStart                   | Maximum frame size of 14745600 bytes excceds maximum space available

So it fails to load a DLL, can’t set the realtime GPU priority and then runs out of space for the frame size. How do I increase the memory for framesize?

Heres also the whole log for further questions:
pastebin (dot) com/K9j0EfKt …damn link filters…

@Netboy3 @Sapiens
Also, this is my shmem config in the XML. The slot 0x0b is not used anywhere else and the memory seems to be the standard value, I will try to increase it to a higher value and report back.

<shmem name="looking-glass">
      <model type="ivshmem-plain"/>
      <size unit="M">32</size>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x0b" function="0x0"/>
</shmem>

Read the “Determining Memory” section of the installation page:
https://looking-glass.io/wiki/Installation#Determining_Memory

Yes, I read that during initital install.
For 1440p, this comes out to around 30 MB. As such I chose 32MB as the next highest power of 2.

Increasing it any further did not help. Even at 64MB and 128MB it still reported having only 13MB available. Maybe reinstalling the IVSHMEM ram driver could solve it?

When I drecreased the resolution to 720p, it worked like a charm!
So It was the memory limit that is the main culprit.

Any pointers on how to increase would be great.

You did shut the VM down all the way and restart it correct? I don’t think any changes in the VM config apply till after a full shutdown (could be wrong).

I did shut it all the way down, i think, will check!

As far as I know the memory calculation on the looking glass site is a little outdated. I calculated that 32MB are required for 1440p as well, however after a recent update I still needed to set it to 64MB buffer size.

after changing the ivshmem size in the XML, try to either reboot your host PC, or shut down the VM and delete the /dev/shm/looking-glass file so it could be re-created with proper size