Return to Level1Techs.com

Looking Glass - Triage

helpdesk
lookingglass
#1725

You’re doing nothing wrong, RedHat removed that header. Unfortunately you have no choice but to move to the latest version in git where this has been fixed, or wait until the next release.

5 Likes

#1726

Hello.
I’m on Arch, kernel 5.05, latest everything.

I have gotten everything set up with a Windows 10 VM, GPU passed through (RX 590), drivers installed, and so on. I have keyboard and mouse set up with evdev, where you mash both control keys to switch.

I then got Looking Glass set up.

It is working at first, but then after about 2-5 minutes it just freezes. The cursor in Windows shows it busy, as if it is accessing storage, and it just freezes. I think Looking Glass is freezing, as when I look into the Virtual Machine Manager app, it shows processor activity continuing and varying for the VM.

I ran
journalctl
to see what came up but nothing looked wrong to me.

What are my next steps?
Thanks

0 Likes

#1727

Hello there,
Sorry for my bad English i am from Germany…
I am on Fedora 29 and i have an Issue with the installation of Looking Glass.

git clone https://github.com/gnif/LookingGlass.git
Klone nach ‘LookingGlass’ …
remote: Enumerating objects: 56, done.
remote: Counting objects: 100% (56/56), done.
remote: Compressing objects: 100% (25/25), done.
remote: Total 4490 (delta 26), reused 55 (delta 26), pack-reused 4434
Empfange Objekte: 100% (4490/4490), 1.03 MiB | 1.05 MiB/s, Fertig.
Löse Unterschiede auf: 100% (2941/2941), Fertig.
[[email protected] ~] cd LookingGlass/ [[email protected] LookingGlass] mkdir client/build
[[email protected] LookingGlass] cd client/build/ [[email protected] build] cmake …/
– The C compiler identification is GNU 8.3.1
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Detecting C compile features
– Detecting C compile features - done
– Performing Test COMPILER_SUPPORTS_MARCH_NATIVE
– Performing Test COMPILER_SUPPORTS_MARCH_NATIVE - Success
– Found PkgConfig: /usr/bin/pkg-config (found version “1.5.3”)
– Checking for modules ‘sdl2;x11;libconfig’
– Package ‘libconfig’, required by ‘virtual:world’, not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:457 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake/Modules/FindPkgConfig.cmake:642 (_pkg_check_modules_internal)
CMakeLists.txt:40 (pkg_check_modules)

– Configuring incomplete, errors occurred!
See also “/home/yajass/LookingGlass/client/build/CMakeFiles/CMakeOutput.log”.

There is an Error with the “libconfig” Package and i don’t know how to fix it can anyone help me with this ?

0 Likes

#1728

try:

dnf install libconfig-devel
0 Likes

#1729

Thanks for the Quick help now it works :blush:

1 Like

#1730

I’m trying to compile with cmake, but get this error message:
LookingGlass-show/client" does not appear to contain CMakeLists.txt.

Searching through the archive LookingGlass-show.tar.gz that I downloaded I cannot find it anywhere.
How can I set tags? This should go under lookingglass.

1 Like

#1731

Hi there I found the youtube article from wendell very interesting about sr-iov. And because of this article I wondered if you could use it to passthrough a sr-iov gpu with a “mainstream” gpu GTX1080 for example. A bit like a laptop with A IGPU from intel and a AMD of nVidia one.

0 Likes

#1732

Can you please show your complete terminal log? It seems strange that this file would be missing as it’s clearly part of the git repository.

In theory yes, but SR-IOV hardware is hard to come by and I do not have any such hardware to test with.

0 Likes

#1733

I tried turning on the VM without a video cable plugged into any output of the secondary GPU. The VM somehow booted and I am able to connect to it, however I cannot change the resolution beyond 1600x 1200. The secondary GPU is an AMD HD 7750. The AMD control panel reports there are no monitors available, custom resolution utility failed on me and if I go into advanced settings an list all modes I can’t go beyond 1600 x 1200 either. The monitor is reported as a “Default Monitor” instead of “Generic PnP Monitor”. Is there any other way of forcing a custom resolution?

0 Likes

#1734

So, just to understand this correctly: everything looking glass related gets mashed into this just one thread that now has over 1600 posts? How is that even remotely useful? Who is going to go through all the posts to find for example my post?

What about subcategories?

0 Likes

#1735

I think time is the issue here. Perhaps a wiki where users could add to it would be helpful.

0 Likes

#1736

LG is evolving daily, it’s a moving target and as such the questions and issues are moving also. This isn’t a “Wiki” or “Informational” thread, but a thread to ask for help in, there are quite a few people on these forums with an excellent grasp on the nuances of LG that are ready to pounce on the problems.

Once we hit Beta I plan to get some substantial documentation together for the official website, until then though the code base is in too much flux.

0 Likes

#1737

You need a dummy plug that presents EDID information for higher resolutions to the system, there is no other known solution to this.

0 Likes

#1738

Thanks, thought so, I was just wondering if there is a software solution.

0 Likes

#1739

Also: I don’t know if it’s normal, but I am percieving some pretty significant delay. It kinda looks like it’s 30fps or something. Is this normal or did I do something wrong? (I have the secondary GPU (HD 7750) plugged into an HDMI monitor and the resolution set to 2560*[email protected])

0 Likes

#1740

EDIT: Aaaaand it’s fixed with 972ff93, nice!

From commit 32bd6d9 make fails to build the client, reverting to 6112162 it still builds.

[looking-glass]$ git checkout 32bd6d96e322271b5b58a4ee1cee05b45e83d1c7
Previous HEAD position was 6112162 [c-host] added initial crash handler stub
HEAD is now at 32bd6d9 [common] implemented crash handler for linux (including backtrace)

[client]$ make
Scanning dependencies of target lg_common
[  1%] Building C object common/CMakeFiles/lg_common.dir/src/crash.linux.c.o
In file included from looking-glass/common/src/crash.linux.c:35:
/usr/include/bfd.h:35:2: error: #error config.h must be included before this header
 #error config.h must be included before this header
  ^~~~~
compilation terminated due to -Wfatal-errors.
make[2]: *** [common/CMakeFiles/lg_common.dir/build.make:63: common/CMakeFiles/lg_common.dir/src/crash.linux.c.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:137: common/CMakeFiles/lg_common.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
0 Likes

#1741

Yeah, @tekfreak on discord pointed it out to me :slight_smile:

1 Like

#1742

im running fedora 29 headless now and trying to get vm->vm with looking glass

looking glass works thats not the problem, i cant get looking glass to connect to the spice server and i know that is is up on the windows vm
i can connect to it through virt-viewer, but that adress i cant use

any answers?

0 Likes

#1743

[[email protected] ~]# virsh domdisplay games
spice://127.0.0.1:5900

channel error: Could not connect to 127.0.0.1: Connection refused

0 Likes

#1744

because your using VM -> VM the spice server isn’t at 127.0.0.1 (localhost), you need to allow your VM to connect to your hosts IP address and tell LG to connect to spice there instead.

0 Likes