Return to Level1Techs.com

Looking Glass - Triage

helpdesk
lookingglass
#1685

Really? c’mon, seriously you can spend a little effort and find the exact program to execute. Did you try hitting “tab” to auto complete the program name? If you are having trouble getting this very basic information how on earth do you expect to succeed with Looking Glass?

0 Likes

#1686

I honestly don’t know which package is the particular qemu you are referring to. Searching on my system I get at least a few different packages that could possibly be qemu that is being used by libvirt.

I’ve already said the version of qemu-kvm I’m using but I also have qemu-system-x86 and qemu is also listed in my apt-cache search however it still does not let me get the version since I have already stated that getting qemu --version returns command not found.

I’ve also tried googling “how can I find out which version of qemu I have?” and various different versions of that same search and from what I can see there are different answers.

I’m trying my best but I’m new to linux so please be patient with me.

0 Likes

#1687

That’s great! I by no means wish to discourage your attempts to learn however please be aware that you have dived into the deep end here and by doing so you are expected to have certain level of experience with Linux.

Hint: On the terminal type qemu and hit tab twice, it will list all the programs starting with qemu that are available. One is very likely qemu-system-x86 as a program (not the package) which you can provide with the --version switch to get it’s version.

Quite often in Ununtu and Debian the package version is not the same as the actual binary version. When asked the version of a program it is best to obtain it from the program directly by some means.

0 Likes

#1688

@trexd seems like im running 2.11.1 and i believe it gets updates on its own with other system updates (unless you would want some dev/unstable version i guess)

example of what i have available on my machine:

im using synergy with dedicated monitor for VM tho, better for my use case rn, so probably wont help you much with looking glass :slight_smile:

1 Like

#1689

I also am using 2.11.1 and have had a great experience with looking glass. One thing i recommend if you just cannot get input to work well is to just pass through another keyboard and mouse. Also make sure you are capturing the keyboard and mouse with scroll lock or the key you set if you changed it.

With the RTX 2060 card I have I just ended up using a cheap HDMI kvm off of amazon and hooked it up directly to the video card, using the type-c port on the RTX as the usb controller. I know it bypasses looking glass, but it works. Just another idea.

0 Likes

#1690

Yeah I definitely only have 2.11.1 but I’m not sure if it would be worth it to upgrade since I just passed my keyboard through and that works fine. The command I used was qemu-systen-x86_64 --version

Would it be worth upgrading to try and fix the stutter issue or should I try cpu pinning first?

0 Likes

#1691

I would try pinning first, then upgrade. I think you’re probably encountering the qemu version issue, but the CPU pinning will probably be easier.

2 Likes

#1692

hey after a few days of messing with stuff i got the driver installed for the shmem file. but it still says run in foreground mode -f for more information
when i run the exe

0 Likes

#1693

Okay, so do that and post the output.

1 Like

#1694

yes my question is how do i run in foreground mode

0 Likes

#1695

Exactly as the instructions state, pass the -f switch.

0 Likes

#1696

do i use -f PATH Specify the path to the shared memory file

0 Likes

#1697

no, run the host exe with the -f switch, not the client.

0 Likes

#1698

do i use HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

0 Likes

#1699

i dont know how to pass the -f switch

0 Likes

#1700

:man_facepalming:

Open a command prompt, and run:

cd PATH
looking-glass-host.exe -f 

Where PATH is the location of the looking-glass-host.exe

1 Like

#1701

oh…
image

0 Likes

#1702

is this correct??

[I]     CaptureFactory.h:83   | CaptureFactory::DetectDevice   | Trying DXGI
[I]             DXGI.cpp:232  | Capture::DXGI::Initialize      | Device Descripion: NVIDIA GeForce GTX 1080 Ti
[I]             DXGI.cpp:233  | Capture::DXGI::Initialize      | Device Vendor ID : 0x10de
[I]             DXGI.cpp:234  | Capture::DXGI::Initialize      | Device Device ID : 0x1b06
[I]             DXGI.cpp:235  | Capture::DXGI::Initialize      | Device Video Mem : 11132 MB
[I]             DXGI.cpp:236  | Capture::DXGI::Initialize      | Device Sys Mem   : 0 MB
[I]             DXGI.cpp:237  | Capture::DXGI::Initialize      | Shared Sys Mem   : 4095 MB
[I]             DXGI.cpp:241  | Capture::DXGI::Initialize      | Capture Size     : 1920 x 1080
[I]             DXGI.cpp:298  | Capture::DXGI::Initialize      | Feature Level    : 0xc100
[I]             DXGI.cpp:335  | Capture::DXGI::Initialize      | Source Format    : DXGI_FORMAT_B8G8R8A8_UNORM
[I]     CaptureFactory.h:86   | CaptureFactory::DetectDevice   | Using DXGI
[I]          Service.cpp:125  | Service::InitPointers          | Total Available : 128 MB
[I]          Service.cpp:126  | Service::InitPointers          | Max Cursor Size :   1 MB
[I]          Service.cpp:127  | Service::InitPointers          | Max Frame Size  :  63 MB
[I]          Service.cpp:128  | Service::InitPointers          | Cursor          : 00000214D5410080 (0x00000080)
[I]          Service.cpp:134  | Service::InitPointers          | Frame 0         : 00000214D5510080 (0x00100080)
[I]          Service.cpp:134  | Service::InitPointers          | Frame 1         : 00000214D9490000 (0x04080000)
[I]             DXGI.cpp:654  | Capture::DXGI::Capture         | Pixel Format     : DXGI_FORMAT_B8G8R8A8_UNORM
0 Likes

#1703

Looks right to me.

Looks like it’s working to me.

2 Likes

#1704

im still met with this from linux

[[email protected] client]$ ./looking-glass-client 
[I]               main.c:1047 | run                            | Looking Glass (a12-131-g10217fc8d9+1)
[I]               main.c:1048 | run                            | Locking Method: Atomic
[I]               main.c:1018 | try_renderer                   | Using Renderer: EGL
[I]               main.c:1203 | run                            | Using Clipboard: X11
[I]              spice.c:197  | spice_connect                  | Remote: 127.0.0.1:5900
[E]              spice.c:742  | spice_connect_channel          | socket connect failure
[E]              spice.c:203  | spice_connect                  | connect main channel failed
[E]               main.c:1253 | run                            | Failed to connect to spice server
0 Likes