Return to Level1Techs.com

Looking Glass - Triage

helpdesk
lookingglass
#1644

The file has nothing to do with the device showing up. Until you get the device into the VM nothing will function, period. What version of libvirt are you using? What distro are you using?, please provide more information.

0 Likes

#1645

fedora 29
QEMU emulator version 3.0.0 (qemu-3.0.0-3.fc29)
threadripper 1950x
16 gb ram 3200 mgh
240 gb ssd for windows
125 gb ssd for linux
msi gaming carbon pro motherboard
gtx 1080 ti for windows
r9 270x for linux

0 Likes

#1646
  1. Qemu is too old
  2. What version of libvirt?
  3. What kernel?
0 Likes

#1647

4.20.16-200.fc29.x86_64
libvirt-4.7.0-1.fc29.x86_64

0 Likes

#1648

Ok, you need qemu 3.10 or later not just for ivshmem, but to fix other issues you will run into. There have been reports of qemu 4.0-rc1 having issues booting (although I am yet to confirm this) so you may want to avoid updating to the most recent release.

Anyone here with Fedora & libvirt experience able to help out with this? @sgtawesomesauce perhaps?

0 Likes

#1649

oh, so i need qemu 3.1 for ivshmem?

0 Likes

#1650

no, 3.0 has ivshmem but it’s got some major bugs. Note that 3.1 is not 3.10

0 Likes

#1651

oh i see, 3.10

0 Likes

#1652

Sorry wait, I have confused myself, it is supposed to be 3.1 minimum. I work on the git master branch so I don’t really track the release versioning.

0 Likes

#1653

thats ok, ill update

1 Like

#1654

You rang?

You have a very similar configuration to me.

Let me compare xmls real quick.

2 Likes

#1655

Okay, first of all, I’m using the following:

<shmem name='looking-glass'>
      <model type='ivshmem-plain'/>
      <size unit='M'>128</size>
      <address type='pci' domain='0x0000' bus='0x02' slot='0x02' function='0x0'/>
    </shmem>

I prefer not to use qemu:commandline if I don’t have to.

You should use commandline or xml-tagged device definition. I recommend using the xml tags.


@The_Poot, start the vm then copy the URL that the following command gives you:

journalctl -x | fpaste

I’ll have a look at your logs.

2 Likes

#1656

It’s also worth mentioning: the /dev/shm/looking-glass file isn’t actually a file. It’s a region of RAM that’s allowed to be shared amongst different processes by acting like a file, thanks to the kernel. (@gnif can probably explain it better than I can)

So don’t think of it as a file (except when setting permissions). Think of it as a region of RAM, since that’s what it is.

3 Likes

#1657

@gnif can probably explain it better than I can

Nope, thats about it :slight_smile:

1 Like

#1658

Hey Gnif,

Thanks for your reply on previous post, been a few days but was away:

The game I’m running is Rust, it’s very ram heavy if that would matter?
If i run it in fullscreen or windowed it doesn’t make any difference in the framerate it seems.

This is the load when running the VM without the game running on it:

2

I’m mostly looking for answers on how to improve the performance with new hardware, since I’m buying a new setup, I want it to also be optimized for this.
Since I have no idea if it’s the cpu lacking in power, the iGPU compared to if I would get a 2nd GPU to run Kubuntu on, the ram,…

I would be looking at a new setup a bit like this:

  • I9-9900k
  • RTX 2080 Ti
  • 32Gb Ram (3200 Mhz)

Unless of course the problem isn’t in the hardware?

Thanks in advance for your advice!

0 Likes

#1659

This is the VM task manager when the game is running:

And this is the load on Kubuntu when the game is running, cpu now goes to 36% but can go, and is mostly at 50 to 60%.

4

0 Likes

#1660

The CPU is not lacking in power, at least not for this applicaiton. the 8700 is a solid CPU.

For the record, I have good performance with Rust on my 1070 Ti, so I don’t think it’s an issue of your system.

What resolution are you running at?

I’d like to have a look at your XML. We might be able to identify an issue there.

0 Likes

#1661

Is there a bug in spice at the moment when keys are pressed they sometimes get stuck? When I press a lot of keys at once (when I’m doing a combo) one or two of them will get stuck.

Here’s my setup. Also when I press a mouse button I lose about 5 frames from what it feels like.

I’ve managed to replicate the issue reliably. If I lose any frames while pressing a key, the key will get stuck until I press it again.

0 Likes

#1662

What are your system specs?

How many cores/gb are you assigning to the VM?


I haven’t encountered this issue, so I don’t know if I’ll be able to help, but I’m just prodding.

0 Likes

#1663

12gb of ram and 8 threads (1 socket 4 cores 2 threads). gtx 2080 and the game is only at 1080p but I get a ton of stuttering. Ryzen 5 2600x

The game and MSI afterburner are reporting 59-60 at all times and when I play the game in pure passthrough it looks much smoother but I can still get my keys stuck. This does not happen with evdev with direct input passthrough but I need my mouse buttons in game so I don’t have that option.

0 Likes