Return to

Looking Glass - Triage



No worries. It sounds like you’re doing something similar to Parsec


We also support Internet Explorer, mpeg1 and websockets.
Not games, but for learning.
Parsec use own client app, Dixper and Rainway use Chrome with webrtc, also for games and not a way to split GPU resources to pieces for lightweight apps.


Sorry, to be clear I was referring to the hosting hardware setup that they are using would be very similar to what you require.


Thank you for clarifying.
Than i’m try Looking Glass with SR-IOV on Tesla based GPU cloud instance.


Looking Glass will work with SR-IOV but it is not designed to work across a LAN, nor can it. It is designed to be used directly on the same PC and has no streaming capability, I do not believe you can accomplish what you’re trying to do with it.


Not GPU streaming. We already implement video-streaming of VM desktop (apps window) with JS based mouse input from client side browser session. We seek only how to efficiently split Cloud VM with GPU(s) for run multiple 3D apps.


Thanks, everything’s working now except when I try to click with the mouse. The cursor keeps going to the top left of the screen… Any idea how to fix this?


Remove the tablet device from the VM


Ahh, thanks! That worked, I’ve got another question. So in KDE, the default task manager in the task bar, when clicked, it shows a list of the windows currently open. But when using the icons only task manager it’s supposed to fill your screen showing this like preview screen of all the windows of that application. When using looking glass, it instead shows a list of all the windows. Now a little while ago I’ve been trying to figure out how to do that exact thing but there’s no option in KDE. But apperently when running looking glass, it does that exact thing, any ideas? lol


I am sorry I have no idea, I do not run KDE, perhaps someone else here can help you.


In KDE when I run looking glass i loose the whole shortcut to do the “Expose” style view. No CRTL+F9 or F10. Not a deal breaker for me as I rarely use it, but i can see where it might be annoying for some users. When i close looking glass, it functions again. For me personally I have started the habit of launching the client on a separate virtual desktop and just switching to it when i need it. Then again, i am only using it for gaming, my dev work takes place in a traditional vm with a qxl video device over spice.

I can see it being something to do with how it integrates the keyboard and mouse and not with spice being it happens still even with the -s option to disable spice integration.

Not sure whats going on, but will gladly test anything for anyone.


Any idea how to make it permanent? As in find a way to get the icons only task manager to behave that way? I’m guessing it has something to do with how looking glass handles the display.


Looking Glass is absorbing all key events to forward them to the client when it has focus, this is by design. Clearly it is a UX issue and will need resolving, I will have a think about it and see what I can do.


Hey, I’ve got another problem. The mouse works fine in windows but when I get into a game, it works for a little while (sometimes just for a few seconds, sometimes for around a minute or two) then it zooms in the screen and I can’t move the mouse anymore. Going into and back out of looking glass doesn’t help. I’ve seen this on the looking glass quickstart read me,

Mouse input freezes or stalls often requiring a reboot of the guest OS to recover.
Please update QEMU, or apply the following patches to your build to fix an outstanding bug in the emulated i8042 controller.

But that post is like nine months old, so I’d assume that the latest QEMU version would have it right? If not how do I patch it then and if it’s already in QEMU, is there anything else that I could do to fix it? I’d prefer not having to pass through another keyboard and mouse.


Are you running A12 or the latest master build?


Yep, running A12.


Fixed the mouse issue by using -j. But I’m still also having the problem where the mouse would scroll in/zoom in the game as well as the ctrl key being pressed randomly.


Random keyboard input during mouse events such as movement is a clear indicator you’re suffering from the bug in Qemu the patch you mentioned fixes. Please be sure you are on a recent build of Qemu.


Yep, you’re right. Apt install qemu installs version 2.11…


Nevermind, that didn’t fix the issue. Updated to QEMU 3.1.0 and I’m still having problems with keyboard inputs not being sent, the mouse scroll/zooming in, and the cursor getting stuck. Any other ideas to what the problem could be?