Return to Level1Techs.com

Looking Glass - Triage

helpdesk
lookingglass
#1675

Yikes version 2.1, how do I update it?

0 Likes

#1676

What distro are you running?

0 Likes

#1677

Elementary OS ~ essentially Ubuntu 18

0 Likes

#1678

I am not familiar with available packages for Ubuntu I am sorry, this again is going to need the help of someone else here. Have you tried searching for “Ubuntu qemu ppa”, someone might be providing newer release builds for your system.

1 Like

#1679

https://launchpad.net/~jacob/+archive/ubuntu/virtualisation

This PPA served my friend well on Mint. Not sure if it’ll work with Elementary though. (can’t hurt to try)

1 Like

#1681

How can I double check my qemu version? I’ve run that and updated everything but I still have the same issue. I’ve also restarted my pc. I used wufrs guide to get the whole thing up and running. Elementary OS 5.0 / Ubuntu 18.XX - VFIO PCIe passthrough guide / tutorial

@wUFr
Did you update your qemu? If so how?

I still have no clue why my game stutters so much in LG, I have the frame counter off.

0 Likes

#1682

image

0 Likes

#1683

Run qemu --version

Any further information/problem reports you provide are useless until you are sure you’re running 3.1 or later.

0 Likes

#1684

command not found

0 Likes

#1685

Really? c’mon, seriously you can spend a little effort and find the exact program to execute. Did you try hitting “tab” to auto complete the program name? If you are having trouble getting this very basic information how on earth do you expect to succeed with Looking Glass?

0 Likes

#1686

I honestly don’t know which package is the particular qemu you are referring to. Searching on my system I get at least a few different packages that could possibly be qemu that is being used by libvirt.

I’ve already said the version of qemu-kvm I’m using but I also have qemu-system-x86 and qemu is also listed in my apt-cache search however it still does not let me get the version since I have already stated that getting qemu --version returns command not found.

I’ve also tried googling “how can I find out which version of qemu I have?” and various different versions of that same search and from what I can see there are different answers.

I’m trying my best but I’m new to linux so please be patient with me.

0 Likes

#1687

That’s great! I by no means wish to discourage your attempts to learn however please be aware that you have dived into the deep end here and by doing so you are expected to have certain level of experience with Linux.

Hint: On the terminal type qemu and hit tab twice, it will list all the programs starting with qemu that are available. One is very likely qemu-system-x86 as a program (not the package) which you can provide with the --version switch to get it’s version.

Quite often in Ununtu and Debian the package version is not the same as the actual binary version. When asked the version of a program it is best to obtain it from the program directly by some means.

0 Likes

#1688

@trexd seems like im running 2.11.1 and i believe it gets updates on its own with other system updates (unless you would want some dev/unstable version i guess)

example of what i have available on my machine:

im using synergy with dedicated monitor for VM tho, better for my use case rn, so probably wont help you much with looking glass :slight_smile:

1 Like

#1689

I also am using 2.11.1 and have had a great experience with looking glass. One thing i recommend if you just cannot get input to work well is to just pass through another keyboard and mouse. Also make sure you are capturing the keyboard and mouse with scroll lock or the key you set if you changed it.

With the RTX 2060 card I have I just ended up using a cheap HDMI kvm off of amazon and hooked it up directly to the video card, using the type-c port on the RTX as the usb controller. I know it bypasses looking glass, but it works. Just another idea.

0 Likes

#1690

Yeah I definitely only have 2.11.1 but I’m not sure if it would be worth it to upgrade since I just passed my keyboard through and that works fine. The command I used was qemu-systen-x86_64 --version

Would it be worth upgrading to try and fix the stutter issue or should I try cpu pinning first?

0 Likes

#1691

I would try pinning first, then upgrade. I think you’re probably encountering the qemu version issue, but the CPU pinning will probably be easier.

2 Likes

#1692

hey after a few days of messing with stuff i got the driver installed for the shmem file. but it still says run in foreground mode -f for more information
when i run the exe

0 Likes

#1693

Okay, so do that and post the output.

1 Like

#1694

yes my question is how do i run in foreground mode

0 Likes

#1695

Exactly as the instructions state, pass the -f switch.

0 Likes