Return to Level1Techs.com

Looking glass run error

./looking-glass-client: symbol lookup error: ./looking-glass-client: undefined symbol: glXSwapIntervalEXT

pop os 21.04
amdgpu
kernel 5.12 acs override

1 Like

Hi,

What version of Looking-Glass are you using? What is your gear? Are you using amdgpu or amdgpu-pro?

amdgpu 5500xt gpu r5 3600 looking glass version b4

If you have installed amdgpu-pro remove it, it’s only needed if you’re using compute. It also has no EGL support.

i didn’t install amdgpu-pro

Well something is very broken with your mesa install then, glXSwapIntervalEXT is a very very common API call and is supported on every GPU going back the last 10+ years.

I think this has something to do with the AMD Binary Drivers. I’m running those as well for a 6700XT and having the same error with looking glass. I did not have the issue with my Vega64 which used the open source driver stack. Once I rig this thing up so the open source drivers work, if I have success I will post back here.

I have confirmed this error has to do with the Binary drivers. A reinstall with just the firmware copied into the kernel with open source drivers functions normally with looking glass and does not throw the error. It also looks like LTS just updated to 5.11.0.25-generic today, I believe I was on 5.8 last night.

what os you are running mine is pop os with acs kernel 12 patch

I’m running Kubuntu 20.04. I had the same error after installing the Radeon
drivers from AMD. I ended up just doing a firmware installation from the github repo for Navi on the 5.11.0.-25-generic kernel and am using the open source kernel drivers.

1 Like

i am having this same issue. updaing the firmware binaries for Navi10 doesnt work and actually kills system performance.
debian 11
Navi10
Mesa 21.2.1
Linux 5.13
Reverting to Linux 5.10 causes no change in this behavior.
i have never installed amdgpu-pro on this system.