Return to Level1Techs.com

Looking Glass - Guides, Help and Support

iommu
lookingglass

#164

Please everyone make very special note of this:

There is a reverse engineered method to enable the NvFBC capture API on consumer cards, it has been published by a third party, and no I will not be linking it here. Using said code/application with Looking Glass puts this entire project in jeopardy, the idiot (putting my feelings lightly) that posted the code is themselves at very high risk of being sued.

The NVIDIA Capture API is bound by the following License Agreement:

In it, it clearly states:

install, use and reproduce the software delivered by NVIDIA, make modifications and create derivative works of sample source code software delivered by NVIDIA and use documentation delivered by NVIDIA, provided that the software is executed only in NVIDIA GRID, Tesla or Quadro 2000+ hardware products that you separately obtain from NVIDIA or its affiliates, all to develop, test and service your products (each, a “Customer Product”) that are interoperable with NVIDIA GRID, Tesla or Quadro 2000+ hardware products

Use of the NVIDIA Capture API with Looking Glass by means of even a third party tool as mentioned above on non “NVIDIA GRID, Tesla or Quadro 2000+ hardware products” would be violating this license agreement.

If people start using this it is very likely going to land us in VERY hot water. Please DO NOT use any such software, either get a supported card or use DXGI DD like the rest of us.


#165

Alpha Version 7 Release

Fixes of note:

  • The host application now waits for the Secure Desktop(UAC, LockScreen, etc…) rather then terminating.
  • The host application now waits around to restart after switching users
  • The KVMFR header format was optimized, old fields removed and restructure to use a “Frame” for cursor shapes.

Windows application needs to be updated, see attached build


#166

what was the patreon link again?


#167

#168

Thanks :smiley:


#170

I’m getting a black screen in the client. This is the client output:

Summary

$ ./looking-glass-client -w 1280 -b 1024 -x 1025 -s
[I] main.c:648 | run | Looking Glass (a6-9-g3784e9c06f)
[I] main.c:725 | run | Initialized OpenGL
[I] ivshmem.c:154 | ivshmem_connect | RAM Size : 33554432
[I] main.c:856 | run | Waiting for host to signal it’s ready…

<<< and then after I press ctrl-c >>>

[I] main.c:860 | run | Host ready, starting session

I’m wondering if perhaps I misunderstood the “supported hardware” documentation – my guest has a 1.5GB GTX 760, DxDiag reports support for WDDM 2.3, which I assume provides DXGI. Guest-side “host application” output includes a “not supported” error as follows:

Summary

[I] CaptureFactory.h:83 | CaptureFactory::DetectDevice | Trying NvFBC
[E] NvFBC.cpp:109 | Capture::NvFBC::Initialize | Capture is not possible, unsupported device or driver
[I] CaptureFactory.h:83 | CaptureFactory::DetectDevice | Trying DXGI
[I] CaptureFactory.h:86 | CaptureFactory::DetectDevice | Using DXGI

Does this guest-side output indicate that my hardware is inadequate?


#171

No.
Capture::NvFBC::Initialize | Capture is not possible, unsupported device or driver
means Capture via NvFBC is not possible which is to be expect unless you got Quadro or higher.
CaptureFactory::DetectDevice | Using DXGI
means it uses the alternative method DXGI (which is provided by Windows through any modern DirectX API).
GTX 760 is perfectly adequate and the host application functions properly for you, you just need to connect via the client application on the host system now.


#172

Great, thanks. Does the client output I pasted suggest why I’m getting a black client window?


#173

Not from what I see. Did you log-in on the guest and make sure you aren’t on a secure desktop?


#174

I finally got it working nearly I have a black screen now though???


#175

Yes, I’m fully interactive on the guest so I can run the host application in foreground mode and see if it ever indicates a connection from the client. (It doesn’t).

Given I don’t see any indication that the client and guest application are actually communicating, it could be there’s an incompatibility between the fresh-from-git linux client and the binary-blob windows guest-side driver and application.


#176

iTzturrtlex, that looks like my symptoms. Could you try running the server in foreground mode (-f) and see if there’s any indication that the client is actually connecting?


#177

Yep exactly the same as you it just says using DXGI


#178

alpha 6 works try that


#179

It seems that with a7 firefox and videogames just give me a blank screen. When i use the the console backend (GTK) it just works and displays fine. a5 is the last version that worked for me.


#180

Is there a way to get it to be full screen without using borderless?


#181

Did you upgrade the client and the host? make clean on the client?

-F flag


#182

Thanks, needs adding to the documentation. No I need to update my host sorry.


#183

Fixed it, the problem was that I unplugged the HDMI from my passed through GPU.


#184

Running the client with -h gives all available options and commands