Return to Level1Techs.com

Looking Glass - Guides, Help and Support

iommu
lookingglass

#205

Looking Glass reports the rate it gets frames from the guest at, not your actual GPU FPS… If you run something that is real time, like a 3d game/application does it jump up?


#206

It does go up but shouldn’t the desktop be 60hz aswell? the menu of assasins creed black flag was 60hz so why wouldn’t the desktop be? it feels very unresponsive overall

just making sure: the mouse escaping to the host os in multi-monitor setups is a known issue right?


#207

No, it shouldn’t go up, the capture API only sends changes, its how Microsoft designed it, NvFBC is the same, the FPS display is the rate at which frames are being received from the host. There is no point capturing frames that are identical.

How do you mean, escaping… hit ScrollLock if you want to capture it to the window


#208

There is no [Spice] requirement, you can turn it off. Your problem has nothing to do with spice, it was failing to sync with the looking glass host. What version of the client were you running?

Interesting. I must have somehow mismatched my client and server. Much appreciated.


#209

Mouse movement feels unresponsive and visually skips, if i switch to the monitor that’s hooked up to the guest gpu it feels normal.


#210

That has nothing to do with frame rate, mouse is streamed and drawn as fast as possible bypassing any frame sync/vsync, etc. It will never be as smooth as the host becase the GPU literally draws it in hardware, its why it’s called a “Hardware Cursor”. We emulate it as best we can, but it will never be perfect.


#211

You using gnome? I had to change a setting to disable compositor Vsync. Was a tearfree xorg setting. It’s in this thread. Tried that?


#212

I’m using KDE Plasma, Where in my xorg.conf would i put Option “TearFree” “false”?

Is this option even for nvidia gpus? when i googled xorg tearfree i got things about intel graphics, i am using an nvidia gpu on both the guest and the host


#213

Does this also apply to moving windows around? that feels choppy aswell, is this because of the bad guest gpu or because of looking glass itself? i don’t want to buy a better guest gpu unless i know for certain that it will be good enough for gaming with using looking glass.


#214

The software is too new at this time to tell, there is varied performance across cards. LG has only been out for a few days… give it some time to mature.


#215

Hitting scroll+lock seems to cause this, but I need that to play games
edit: it also seems to be a problem with my razer mouse, it dosent do it with my other mouse


#216

Alright thank you very much for developing it and being very helpful.


#217

I am now having these same connection issues using the alpha7 client (what happens is already explained in the quote)


#218

(a5-12-gb89a8fee04) = alpha 5


#219

i haven’t updated the ouput in the quote

[I]               main.c:648  | run                            | Looking Glass (a7-1-ge6c6c16d56)
[I]               main.c:725  | run                            | Initialized OpenGL
[I]            ivshmem.c:154  | ivshmem_connect                | RAM Size : 16777216
[I]               main.c:856  | run                            | Waiting for host to signal it's ready...
[I]              spice.c:341  | spice_on_common_read           | notify message: keyboard channel is insecure
^C[I]               main.c:860  | run                            | Host ready, starting session

(same issue as before)


#220

Did you update the host software too?


#221

yes, was already using alpha7 for the host software


#222

Already with alpha 5? I dont think so, they are completely incompatible.


#223

I am using alpha7 from the download link on the website


#224

Make sure the host software hasn’t crashed, check task manager. If not, ensure you didn’t stop the ivshmem-server, and if you did you need to turn off the VM before starting it again.