Return to Level1Techs.com

Looking Glass for Centos 7?

Hi,

Im trying to run looking glass on centos 7 but I’m having some difficulty. I tried to build it on ubuntu and fedora and use the build on centos but it gives a libnettle package error. Is there a way to install/use looking glass on centos ?

Thank you

That won’t work, binaries are not portable like that most of the time. It can work, but it doesn’t always. Between Fedora and CentOS there’s a bigger chance it’ll work, but even then package versions are different and might be incompatible.

Build it directly on your CentOS installation instead. The build instructions are the same as Fedora. Might need an additional package or two depending on errors you get.

1 Like

So I’ve tried to build it on my CentOS machine and it worked up until Make.

I get this error:

cc: error: unrecognized command line option ‘-Wimplicit-fallthrough=2’
make[2]: *** [common/src/platform/linux/CMakeFiles/lg_common_platform_code.dir/crash.c.o] Error 1
make[1]: *** [common/src/platform/linux/CMakeFiles/lg_common_platform_code.dir/all] Error 2
make: *** [all] Error 2

I’ve installed devtoolset-9-gcc-c++ , but with the same message.
Any idea what I could do?

Thanks

Not really familiar with the codebase so I can’t really say much about that. You can try removing the flag since it’s more important for development then end-user compilation anyway. Not sure why it fails though since that flag should be available as of GCC 7.

edit: then again, your error message has the cc: prefix, not gcc: like it should(?), so I’m not sure if it’s using the correct compiler (if cc is not a symlink to gcc). Might just need to cmake again after the gcc-c++ installation.

Your GCC is too old and Wayland is too old. here’s how you should build:

  1. install EPEL: sudo yum install epel-release
  2. Install SCL: sudo yum install centos-release-scl
  3. Install all the dependencies: binutils-devel cmake3 fontconfig-devel SDL2-devel SDL2_ttf-devel spice-protocol libX11-devel nettle-devel wayland-protocols-devel gcc libXScrnSaver-devel libXfixes-devel libXi-devel wayland-devel devtoolset-9
    (I hope I didn’t forget anything)
  4. in the source tarball, cd client; mkdir build; cd build
  5. cmake3 -DENABLE_WAYLAND=0 ..
  6. Now to build with gcc 9 you’ll need to setup the environment to use gcc9: scl enable devtoolset-9 bash
  7. now do make and it should build.

Please note that there might be runtime issues there. CentOS7 is simply too old and a very rare choice for a desktop client application such as LG to be maintained.

2 Likes

Your solution worked out. Thanks a lot!