Return to Level1Techs.com

Looking Glass Capture Second Guest Monitor Win10

I’m trying to get looking glass to capture the non-main monitor in my guest Windows 10 VM. I have a dummy plug for it, but if it’s set to be the main, I cant see security pop up and the stuff Windows does during restarts and shutdowns with updates. So, I have a second monitor plugged into the passthrough gpu that I would like to make the main while LG grabs the secondary screen.

I have seen on the git and on reddit to use the input: looking-glass-host.exe dxgi:adapter=XXX dxgi:output=YYY but having tried many different combinations of numbers I am not getting any changes to LG, it just continues to show only the main monitor from the guest.

I have also seen to do looking-glass-host.exe -k to get a display with available options, but after running it nothing happens, just like with the other line. I get the request for acceptance from windows security, then I say yes and nothing happens.

Should I be making an ini or something like the readme says I can do with the linux side? I just don’t seem to get results and I would love to have looking glass as a second monitor to my main, not just a duplicate.

I don’t even see anything running in task manager for looking glass after I stop the auto-start instance, even though LG continues to work. Even if I just run the command normally, like how I used to start it.

Don’t know if it affects anything, but I still have the QXL virt window going while I try to get the second display set up correctly.

CPU: AMD TR 1950X
GPU: Host: RX 580 Guest: RX Vega 64
OS: Host: Manjaro on Linux 5.6 Guest: Win10 1909

Thanks for any help!

Please show both the client and the host logs.

The host log is located at %TEMP%\looking-glass-host.txt

Sorry for the slow response, and thanks for the fast reply. I went to bed thinking I wouldnt see a response for a bit.

Here are the log files from the host, I’m not sure where the log files for the client are, unless you want the terminal output after i run the program in the terminal?

looking-glass-host.txt (181.7 KB)

Thanks again for any help

yes please

$ looking-glass-client -s no -M no
[W]             option.c:288  | option_parse                   | Ignored invalid argument: no
[W]             option.c:288  | option_parse                   | Ignored invalid argument: no
[I]               main.c:996  | run                            | Looking Glass (B1-rc6-5-g8ad2d5f949+1)
[I]               main.c:997  | run                            | Locking Method: Atomic
[I]                egl.c:187  | egl_initialize                 | Double buffering is on
[I]                egl.c:201  | egl_initialize                 | Multsampling enabled, max samples: 4
[I]               main.c:902  | try_renderer                   | Using Renderer: EGL
[I]               main.c:1183 | run                            | Using Clipboard: X11
[I]               main.c:1259 | run                            | Waiting for host to signal it's ready...
[I]                egl.c:447  | egl_render_startup             | Vendor  : X.Org
[I]                egl.c:448  | egl_render_startup             | Renderer: Radeon RX 580 Series (POLARIS10, DRM 3.36.0, 5.6.3-2-MANJARO, LLVM 10.0.0)
[I]                egl.c:449  | egl_render_startup             | Version : OpenGL ES 3.2 Mesa 20.0.5
[I]               main.c:1268 | run                            | Host ready, starting session

Thanks for the better edit, I’m garbage at this.

Okay, newest update @gnif. I removed the virtual spice window, it didnt make a difference. I realized I’d messed up and for some reason was using -f instead of -k, but after trying with -k, no difference, it just restarted looking glass.

I also, took the arguments and put them in the autostart script since it kept saying I was trying to grab an in use device if I ran it after windows start up. Also didnt help, but it did change one thing. LG stopped autostarting correctly after that, until i clicked the Desktop shortcut to get it to just capture the main display again.

I also tried an ini, but that seemed to get completely ignored and made no real difference. I lastly tried shutting the whole VM down between changes, just to make sure the memory was getting released. It was part of the no start of LG, but at least showed the change, i didnt try restarting instead afterward, as it was worth seeing if any of the changes worked.

I have done every output from the first 2 displays to requesting a non existant 3rd one. All with adapter 0, I shouldve tried 1 at least once after the full shutdown testing, I guess. Might try that later, but I’m basically out of ideas.

Here is the newest log from within Windows, let me know if you come up with anything else I can try. Thanks!
looking-glass-host.txt (284.9 KB)

LG requires Admin privileges to run, as per the instructions on the wiki you MUST create a scheduled task that gives it these permissions to run at startup. The exact command is given

I already do, the autostart works without the arguments added, but as soon as I add them it stops working and wont pick anything up. Just gives the purple screen until i start it manually by just clicking the icon.

Are you adding the arguments in the sheduled action Add arguments fieid?

2020-05-03-145330_454x499_scrot

Yes, but I tried in the program section too and Windows moved it for me.

Please show the exact arguments you are adding

Okay, here you go. I’m really hoping this is a user error thing, and you just point out that I did something dumb.

Anything obviously wrong @gnif?

I’m not actually sure where you get the adapter number from (was told 0 in a reddit forum), but I’ve tried a lot of different combinations as well. So, now I’m not sure what else to test anymore.

I will likely test this on my friend’s setup tomorrow and see if it works for him, but if there is a glaring problem, I’d love to know what it is. Thanks again!

Not that I can see.

It’s just an incrementing number, the first adapter will be 0, the next 1 and so on. Windows orders them how it sees fit.

Well, that sucks…but it seems like I might be hitting a bigger problem anyway with my GPU 100% in 3D games and making LG’s UPS plummet. So I’m gonna let this one go for now and play with it in a later update, unless you want me to send you any other stuff.

Thanks for all the help @gnif!