Return to Level1Techs.com

Looking for tips from successful Linux + 5700XT users

I just recently built myself a new ‘gaming’ PC with Ryzen 3800X and the intention to dedicate the system to Windows gaming. As part of that I would move my 1080ti from my workstation over to the new PC and I bought a new Powercolor Red Dragon 5700XT to go back into my workstation. Open-source graphics stack! :slight_smile:

Well, I’ve had trouble. I was running Pop!_OS 18.04 quite happily for a year or two and it would lock up, that is, the graphics output would lock up, after several days of uptime. I could still ssh into the system so Linux wasn’t locked, just graphics. I couldn’t install the AMD driver package because of the kernel mismatch. With Ubuntu 20.04 so close at hand I installed that in another drive and gave it a shot. Even worse. Still can’t use the AMD package and the in kernel driver + stack was not happy. I got inconsistent locks of various kinds with some nasty junk in journalctl. I finally threw in the towel when I couldn’t find any search love on the ‘pause’ errors I was seeing.

So I put the 5700XT in the gaming system. Performance is pretty good considering this is a ‘mid-range’ card. But even in Windows I’m getting game crashes.

So what’s the point of this post?? Not to complain and gripe. The card itself is very impressive. Superb build quality and it is nice and quiet. I’d like to use it for the purpose I intended, as a Linux card where the most demanding thing I run in Stellaris usually. So, fellow 5700XT owners that also run Linux, have you any tips for getting stable performance out of this card?

I am continuing my own research. I just threw another drive on the Ryzen gaming system and installed Ubuntu 18.04.4 HWE and installed the offical AMD driver, the open-source one not the pro. I want to see what kind of stability I get out of that. But if it is golden I am still somewhat concerned because with the 1080ti it has never mattered what I run, it just goes. So I’m beginning to wonder if this ownership will always be a struggle or worse I am stuck with very specific OS releases and kernels. Am I just missing some specific AMD graphics on Linux knowledge?

You’ll want the newest kernel and in general the newest version of everything.

Sure it’s the GPU? I thought problems were fixed by now.

1 Like

I certainly have not been methodical in my testing. But the 5700xt is the one constant. With that card in a system there’s problems. Same system, put in the 1080ti and problems go away. Two OS’s on the same threadripper I’ve used daily for 3 years.
My test with the open-source drivers on 18.04-4 didn’t last long. Hard lock just a few minutes into Stellaris. I removed them and installed the pro. So far, close to an hour, no problems.

I also thought kernel 5.3 and newer resolved all the problems. What I’m trying to determine is if there’s a path to success with it. At this point I can still send it back and stick with Nvidia. I don’t want to but chasing locks and hangs isn’t what I find fun.

I do have a 580 I can test with as well. That’s another thing…it could be this particular card and not 5700s in general.

GPUs are not getting more expansive* and we are not running out of them either**. If you have a card that works for you and you have problems with the new one, switch back and wait. Navi X2 is coming at some point and as an architecture it is here to stay for a while.

*(Fuck off, miners!)
**(Seriously, FUCK OFF!)

Kernel 5.3 added support but Kernel 5.5 added all the parts needed to actually run the card. Even then, it seems like some of the cards are just having issues possibly due to firmware.

As Noenken said, you need the latest Kernel (5.5 at least), the Latest linux-firmware package, LLVM-9 (10 for new features), and latest mesa (At least 19.2).

1 Like

Kernel 5.5.* is the one that’s supposed to solve the problems AFAIK, not 5.3.*. I run 5.5.17 at the moment (Radeon 5700), open source drivers. Runs great. Installing AMDGPU drivers is a terrible experience, and not really worth it.

OpenCL support does not ship with OSS drivers yet, if you care about that, but you can kinda build LLVM10 with support if you’re handy with code. Had some success with that, but I’ll just wait for Fedora 32 (supposed to be released next week), that’s shipping with LLVM10.

2 Likes

Thanks for the feedback. This is exactly the kind of info I’m looking for, really appreciate it. Sounds like it might be time for me to move back over to Fedora where getting the newer kernels is easier. The whole point of my moving over to Ubuntu LTS is to have a stable and boring platform but if I’m installing out of release kernels that kind of breaks the paradigm.

OpenCL is a nice to have but I don’t need it. I really only play with GPU crunching in Handbrake but I find the CPU algos are better quality (NVEnc is super fast but the file sizes are outrageous).

What are you guys using? Fedora? Arch? Debian + custom kernel?

Fedora 31, completely stock. The kernel updates often, so you’ll have a recent one always. I don’t distro-hop at all, that’s why I bought an AMD card in the first place. Updating Nvidia drivers every time the kernel updates I find extremely annoying, even if automated.

F31 is running mesa 19.2.8 and LLVM9 at the moment, so disregarding OpenCL my Radeon 5700 is doing great and I’m eagerly waiting for F32 to get it running. I’ve only had a significant annoyance maybe once after an update (pulseaudio, made the mic on my ThinkPad disappear into another dimention) and very minor inconveniences apart from that. That’s in a span of 5-6 years.

1 Like

I’ve had no issues with my 5700xt since I upgraded to F31

Okay I’m on F31 now, 5.5.17-200.fc31. No problems so far. I’ll push it harder later when I’m not supposed to be working. I’ve had this install since probably F28 if not earlier and it was my main system for years. I moved over to Ubuntu/Pop LTS to get more familiar with Ubuntuland since I’m now the main Ubuntu guy at work and the Citrix Workspace thick client is supported. But that’s no longer an issue since I dedicated a laptop to work. I do wonder if it is worth fresh installing Fedora.

Reporting back to close the loop. I appreciate everyone’s input. The 5700XT was stable in Fedora 31 and I was settling in to make it my daily workstation but I ran into completely unrelated EFI boot issues. Basically, with different combinations of nvme drives in the the system the boot loaders on the drives would or would not be available. Once you get into a system that will boot you can see and access the drives but EFI doens’t see it at boot time. I’ve seen the problem before and thought maybe a reinstall of Fedora on that drive might correct it and a fresh install sounded good to me. Didn’t resolve. Okay then, that’s fine; I’ll just use grub on whichever one boots to boot into the other ones. Well, no such doing. Fedora didn’t see anything else. Os-prober came back null. Ubuntu saw some other Debian based systems but not Fedora. It was a confusing mess that’s hard to sort.
Somewhere in all of this I began to realize that I was fighting a battle I could walk away from. I stopped using the 580 on the Mac because the Mac can’t restart with the eGPU attached and wasn’t worth the hassle. So I stuck the 580 in the Threadripper and booted into Ubuntu 20.04 and it is solid as a rock. The most demanding thing I do graphically is play Stellaris and the 580 handles that with no problem. The 580 has enough display outputs for me so it will do fine.

I have to admit I wanted a shiny new toy and didn’t think this through well enough. So I’m sending the 5700XT back. Also, I’m using the U.2 port on my motherboard and I suspect it is doing strange things to the onboard nvme. The manual states 1 certain nvme slot is disabled when U.2 is in use but I am suspecting it might not be that simple. I know the slots are active because the drives function once you get into a running system but perhaps the EFI logic just can’t handle it at boot time. To eliminate that and provide more flexibility I bought a PCI U.2 card so I can move the drive around and free up all the nvme slots. I’m very curious if that change will resolve the boot loader issue (BIOS doesn’t even see it). If not, I’ll dd that ssd and try again. I hope to figure it out eventually.

3 Likes

Thanks for closing the loop. Curious what your mobo is? I have a U.2 on one of my mobos and it seemed like the time for that interface has come and gone :slight_smile:

The TR mobo is an Asrock X399 Professional Gaming. I later discovered that the U.2 interface and that particular motherboard has nothing to do with the boot issues I encountered. Instead, there’s some sort of UEFI bootloader issue going on. I recently built a new gaming system based on Ryzen 3800X I can use as a less complex example:
This X570 mobo is simpler and has just 2 m.2 slots. I have Windows on one and Fedora on the other. If I have just 1 m.2 drive in the board it will boot either one just fine. If both are populated with those OSes the BIOS won’t see Fedora to set a boot priority. However, if you hit F11 at boot you can pick it and boot to either one.

So that’s the same thing I saw on the X399, just it is more complicated there with so many drives. U.2 is made for datacenter and I don’t know if it is long for this world on workstation and high end boards. Seems easier in most cases to use one of those m.2 expansion cards Wendell is fond of instead. But it’s cool and if I have the tech I want to try it out. And the drive I have was a new-old-stock bargain I got on the cheap. So that’s pretty awesome.

I transitioned the X399 system to being a Proxmox host and it and the U.2 drive are doing fantastic there. I made that jump after discovering the IOMMU grouping is very unfortunate on the Asrock X570 Steel Legend (802.11ax) and can’t believe I waited so long to try it. Big home lab improvement.