Looking for help diagnosing weird network bandwidth limitation

Hello Level1Techs, hoping your brains can help me out. I tried on reddit but got no traction to this problem.

Hopefully someone can help me diagnose this, as I’m out of ideas and it’s annoying me.

New Build as of this year. (PcPartPicker link). Everything has been working fine with it, up until about a month ago (ish). My go to speed test is https://speed.cloudflare.com/, and it has always worked reliably. My home comcast connection is 300/15, and every other computer in my house gets consistently between 320-350. No issues there.

Normal Result from every other machine

My Problem Machine

On this computer, the speed test maxes out at ~30Mbps no matter how many times I run it, And the visual indicator just plateau’s at 30Mbps, no matter the size of the download. I know for a fact I’ve seen it at 300+ the same as any other computer in my house, but for some reason now, it’s plateauing at 30Mbps and it’s annoying the hell out of me since I can’t figure out why. It doesn’t appear to affect all applications, as launchers (Steam, UPlay, etc… ) still download at ~20MB (when I check them). I’ve noticed some other odd network cutouts, but not repeatable enough to nail down or diagnose. I don’t like things not working that I can’t identify so would appreciate any help.

Things I’ve tried

  • Swapping patch cable (multiple, same result)
  • Swapping switch (laptop plugged into same switch doesn’t have the issue)
  • Swapping NICs (Motherboard has an Intel & Aquantia, same result)
  • Turning off/on Large Send Offload (same result)
  • Drivers & BIOS are up to date (for all devices in the system)
  • Windows is up to date (Windows 10 Pro 2004, build 19041.572)

I will update this list with any new ideas people have me try and what the change in results are, if any.

What you could try for a test is booting,
a linux distro like Linux Mint live session from a usb stick.
And then do those speed tests again.
If you get normal speeds, then we know for sure it’s an issue related to windows.

1 Like

Also did you already tried to switch powersaving mode to high performance?

so apparently I never got an email that you replied, my apologies. Many thanks for offering help though. I switched power plan to “AMD Ryzen High Performance”, no change. downloading linux mint distro and will live boot with that and post results shortly.

It could also be that Windows just takes a large chunk of your bandwith.
This is a setting that is in the Os by default.
If you use 10 pro you can sorta disable this by editing a setting in the group policy editor.

1: Open the group policy editor.
2: Go to: Administrative tools > network > Qos package scheduler.
3: Click on limit reserved bandwith:
4: Click Enable and set a precentage of 0% (zero %)

Maybe that could cause your issue.
Or at least it might be worth trying. :slight_smile:

It could also be that this is just a deeper laying problem.
That´s why a test run with a linux live key could give some more info.
Because when you don´t experience issues in Linux.
Then we can be certain that it is likely a software / windows issue.

tested with Linux Mint flash drive, no issues with speed test. got my expected 300mb+ downstream. I agree that’s a pretty good indication that it’s something in Windows.

I will check under the Package Scheduler you mentioned earlier when I get home in a bit.

Check GPE, all policies underneath QoS package scheduler are set to “Not Configured”.

I’m definitely thinking it’s a software/windows thing, I’m just really curious to know why Cloudflare’s Speedtest is capped on this system only. It’s not affecting the entire system (steam updates still haul), and I just tried some other speed test sites (Ookla), and it came back with what I expected of 359/12, it’s only a speed test with Cloudflare that is coming in with a hard cap, which I can’t reproduce on any other system on any other network.

It might be worth noting if you do upgrade/swap network cards, you may need to use Windows “reset network settings” so the current NIC becomes default which clears the previous NIC’s custom network settings.

From past experience some cloud services including content delivery services do cap/throttle, many years ago I think it was CNet had a writer compare cloud storage providers and the results were very interesting.

Yeah by default it’s set to “Not configured”.
Which pretty much means that windows take as much bandwith as it wants,
for “stupid” things like checking for updates etc etc.
This is one of the annoying things with how Microsoft vagely words their things now days.
Although it´s maybe not related to your problem.
But it might be worth trying.
You can always set it back if it doesn’t do anything for ya.

Maybe a stupid question:

Did you already try switching the powersaving mode,
in windows10 itself to high performance?

Other things that come to my mind:

  • Maybe some update is causing it.
  • Driver issue.
  • Something with the network stack on your installation being wonky.

Doe it show as having negotiated a full gigabit connection? Can you make a crude network map for us?

Sometimes these things manifest at issues with the OS, and maybe they are to some extent. I’ve seen it where a single device acts up until you reboot or move it to another piece of gear.

Window shows speed on the adapter at 1.0 Gbps. I also tried swapping the switch the computer was connected to out to test that, but problem pc was still capped at 30Mbps, while other computers to same (new) swtich tested fine, so switch doesn’t seem to be the issue.

I just did the Windows 10 “Network Reset”, no change, using either NIC (there are two on this motherboard, ASUS Crosshair VIII Formula)

Apologies, misread your original post. I tried setting the “Limit reservable bandwidth” to 0%, no change, including after reboot across multiple browsers.

Changed to regular “High Performance”, also no change (including after reboot).

All signs so far point to something within this Win10 install, I’m just failing in my googling to try and isolate / debug what it could be.

Regarding your comment about updates or driver issue. Is there anything I can do to try and diagnose that without resorting to uninstalling each KB update one by one to see if anything changes?

Just create a spreadsheet showing my problem desktop and my laptop, both connected to same switch, both on same version of Win with same updates, across five different speed test sites.

It seems like traffic is getting package shaped on my desktop, but I have no idea what could be causing it.