Looking for a little help (dxvk/proton)

First post; Sorry if I’m the wrong section for this.

I use Arch or Manjaro as my daily driver, depending on how lazy i’m feeling when installing :stuck_out_tongue:
I recently heard about dxvk, proton , and all that good shiz. Idgaf if the games take a bit of a performance hit. It would be nice not to have to reboot into windows to play a casual session of overwatch or the forest or something.
Edit: Nothing casual about The Forest. XD

Here’s the prob:

I tried proton on my laptop (manjaro: i7 4th gen integrated graphics) and other than the initial stutter on the first run or 2 it works great!
But when I tried on my desktop (manjaro, antergos, and vanilla arch: fx 8350/gtx 750 ti) No such luck.

I was using Manjaro but had issues being able to install the driver I needed. So I tried Antergos. I was able to install the driver, but still had the same issue. The games run super slow. Games that, like in the case of marvel vs capcom 3, ran great on my laptop’s integrated graphics.

Here’s what I did:

  1. Installed nvidia-vulkan https://aur.archlinux.org/packages/nvidia-vulkan/
    (also tried nvidia and nvidia-dkms from official arch repos)
  2. installed nvidia-vulkan-utils and lib32-nvidia-vulkan-utils
  3. Installed opencl-nvidia-vulkan and lib32-opencl-nvidia-vulkan
  4. Installed vulkan-icd-loader and lib32-vulkan-icd-loader

Have I missed a step? I have seen youtube videos of others running games in proton and dxvk on a 750ti and it looked great.

I watched Wendel’s video and he said if we had any questions to ask on this forum, so i thought i’d give it a shot.

Any help is greatly appreciated.

Thanks in advance!

I managed to install the nvidia-vulkan driver in Manjaro, the issue persists. Updated steps taken.

I’ve tried a few games now and, they all suffer from the same slowmotion. they look great, but incredibly slow.
Ultimate Marvel vs Capcom 3
The forest
Monster Hunter World
BioShock (2)

Dota 2 on vulkan runs great, so I’m still pretty lost as to what’s happening.

Did you enable Esync? Proton has Esync on by default and hitting the limits with Esync on can result in these kinds of slowdowns:

Thanks for your reply, FJ.

I did try this, unless I set the launch options incorrectly:
PROTON_NO_ESYNC=1 %command%

It made no notable difference.

You may need extra steps for Optimus/PRIME, since you’re on a laptop. Are you sure the GPU is running in high performance mode in nvidia-settings? Is your CPU governor set to performance?

It is not optimus. My laptop only has intel integrated graphics, but it is running games fine in proton. My desktop has an nvidia gtx 750 ti. That is the one running slow.

I did set my opengl settings in nvidia-settings to high performance and my cpu governor is set to performance.

You could try using pcie_aspm=off as a kernel command line parameter to see if it’s the PCIE bus screwing up.

If it was the pcie bus, wouldn’t it also have issues in Winblows? I still have no issues gaming in windows. Nevertheless, I’ll try passing pcie_aspm=off. Thanks trying to help me narrow it down, FJ. :slight_smile:

I’ve had similar slowdowns in a Linux VM in Unigine Superposition and it got resolved by turning off ASPM. ASPM is turned off in Windows once you choose the “High Performance” power plan, but requires a kernel command line value in Linux.

I tried disabling aspm but it made no notable difference. Unless I did it wrong.


Could just be that those games simply don’t run. Check out some of the games on the officially supported list or look up games that have platinium rating at https://www.protondb.com/ if you have any of those, and see if they run as they should.

Alternatively you can try different runtime configs as listed on the github page (the last item on the page): https://github.com/ValveSoftware/Proton/
Personally I haven’t played with them at all, if it hasn’t worked, I’ve just moved on.
You can always make requests on titles that you can’t get running to be fixed, or maybe someone already has a fix for them… Might be worth checking out the steam forums for a solution as well.

EDIT: Also try different versions of proton, if you haven’t already. I’ve had games almost no running at all on the newest beta but run perfectly smooth on the steam recommended version.

Thanks for the reply, Vood.

Normally I would agree except that some of these games run on my laptop, and on integrated graphics at that.

Nevertheless, I will give it a shot and report back.