Logitech webcam - they're really scraping the bottom

Hello dear community. I know the title of this post is a bit of bait, but that’s just in the hope that you stay for a decent story of daily tech issues in my life.

I was looking for a new webcam for my new desktop and I was daily scavaging some local retailer’s sites + Amazon for a good deal on a Logitech webcam. I used a Quickcam Communicate STX and a C920 (gave it to my brother), and I’ve always been amazed at how well they work (picture quality, mic quality, software adjustments).

And than, a few days ago, what I thought was a grace: an Amazon return on a Logitech Streamcam discounted by about 55€ which made it the best deal I’ve seen in months on a good webcam due to Covid.

Fuck it, I decided to buy it and see what would happen. I get a generic brown box with the webcam, the mount for a tripod, the safety guidelines and the 3 months Xsplit code.
I take it out of the box and the thing is brand new, not even a light scratch from a fingernail, nothing! The cable still fits snug in my USB C port and is just as new as the body and lense.
I was kinda excited because I thought I scored a good deal.

Plugged it in, immediatly recognized, no driver needed from Logitech so I jumped into W10 camera to take a look at the picture quality. It’s C920+, same behaviour but 60fps capable and more vibrant colours. What I expected to see. One weird thing struck me: no 60fps video.
I thought it was a feature locked in Logitech Capture so I downloaded it and right there I opened Pandora’s box.

I got greeted with a message that said I didn’t plug my webcam into a USB 3.0 port so I couldn’t use 60fps recording.
Alright, a good’ol unplug and plug back in will fix it. Well it took more like 6 attempts and the one that worked involved keeping Logitech Stream open, unless it wouldn’t work.

Okay, no need to panic just an hiccup. Did a test call on Skype and it worked well. Than I saw “stereo mode” for the mics. Cool, that might make calls more human feeling! As soon as I turned that on my voice is unintelligible and echoes like I’m speaking into a mine.
FFS what’s wrong with it? I tried to change the audio bitrate in Windows, unplug and re-plug it a bunch, uninstalled drivers, re-installed. Nothing worked.

Still not too bad, just a small feature I can’t use I can live with that.

Used my PC, rebooted because I installed some programs and later I decided to check on it. Wouldn’t you know, the same fucking thing as before: you need plug your device into a USB 3.0 to use it to it’s full capabilities or however that message was.

The last chance is waiting for Logitech’s response. If they say it’s defective I’m gonna throw it with my bare hands directly into the Amazon warehouse it came from.

tl;dr Thought I scored a deal for a Logitech webcam, but it turned into a tojan horse of issues.

Thanks for reading, I hope I made you laugh!

1 Like

You should see all of the quirks just to support Logitech’s newer (at least five years old) keyboards and mice in the Linux kernel.

They are not the company that they used to be. They have gone the way of Altec Lansing.


Yeah, and since peripherals get more and more complex as time goes on they require more specialized drivers and software to be fully taken advantage of.

I thought as Logitech as the Nokia of peripherals. I had one of their first wireless mouse and keyboard set and it was amazing. The keyboard is still working after 20 years (PS2 trans-receiver and mouse with a ball).

I still have a few old logitech stuff from the USB 1.1 and 2.0 days. Still work, but i use them as spare devices. Any of the new stuff I bought, I ended up giving away because the buggyness. I am a GNU/Linux user so installing their software and drivers were out of the question.

I am at the point where I am the old guy saying “They don’t make stuff like they used to anymore.”


And I’m the old guy asking …

Did they ever?
Or am I just getting to old to remember?



The plot thickens: I tried to connect the webcam to my work Intel laptop and it works like a charm. Audio is perfect both stereo and mono, no errors regarding using a USB 2.0 connection, NOTHING!

This is so weird: the webcam is not connected to a different USB controller on the board (like the AsMedia stuff that can be finicky). On my Crosshair VIII Impact all the USB ports on it are handled by the AM4 chipset. No other device has ever gave me any issue on this machine.
I asked Asus aswell what to do because I really don’t have a clue. Thought about updating the chipset drivers but there’s something weird with the versioning that I don’t understand and I can’t mess up my machine right now.

Good stuff and bad stuff gets released > time goes on > only the good stuff survives > people see the good stuff (the crap stuff is long since forgotten) and come to the conclusion that stuff must have been better then

That being said, there are some areas where I think this is true. But for PC hardware, for the most part, I don’t think it’s the case

1 Like

Fair point.

I think @YerDaSellsAvon hit the nail on the head. I have been using Unix-Like systems as my main since '99. As such, before you bought hardware, you had to be damned well there was support for it or you would have to do the leg work. Most of the stuff that I bought was mostly tested and supported by others, but there were some things that I had to tweak to get them to work reliably. Most of my old hardware consists of microsoft peripherals believe it or not. I have a logiech web cam and a wireless logitech keyboard and mouse combo with multi-button and multimedia controls. They are the only things that have survived with in kernel support and with minimal quirks. The other stuff had stopped working because it was not being driven correctly, I got tired of supporting the drivers, or physically broke down.

1 Like

How much power does webcam need?
Is it possible that MB is putting too low of voltage or can not push enough current? Maybe your MB has voltage on USB on the lower side of acceptable range…

Do you maybe have a powered hub to try and test if it works?

I have a 64gb usb, that only works as 3.0 on powered usb hub and one port on my laptop.
Otherwise it seems it’s too finicky with voltage & works in 2.0 mode…

USB power is not an issue, unfortunately. I’m on an Asus Crossair VIII Impact and I tried connecting it to different USB ports with an adapter but the issue doesn’t go away.

They still make the logitech G600 mouse that I’ve been using since 2015. First one I had got beat to hell playing Diablo 3 and modded minecraft back in the day with friends but the damn thing still works . Got a new one in 2019 cause a button got sticky on it, but the build quality seems to be just as good as the one I got in 2015. Only thing I noticed; it doesn’t hold it’s DPI settings like the 2015 model. Doesn’t matter since I adjust it myself on Linux but still a bummer

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.