Return to Level1Techs.com

Logitech 4K (BRIO) fails in Ubuntu 18.04

I know the power of Linux is strong here so since I can’t seem to find the answer anywhere else I decided to try here first.

My buddy and I do a live YouTube sports show and now that he has his own place. He wants to make his own studio at his house because he has a room perfect for it. I have to build him a new computer to live stream and record to. My problem is getting Ubuntu 18.04 to work properly with a Logitech 4K (BRIO) webcam. I am doing the testing on an older machine that has an ASUS TUF SABERTOOTH 990FX R2.0, AMD-8350, 32Gigs of ram, RX580 8gig, and a 250ssd running Ubuntu 18.04.03 LTS.

The problem I’m running into is when I start OBS Studio everything is fine but when I go to add the camera like I did with windows (my main machine) I get this flashing black and white video preview. There is a drop down for that camera and it shows another stream for that camera so I choose that and it seems to look correct. Then when I go to adjust anything else so I can set it up as 1080p 60. The program friezes up and the camera and my USB mixing board is no longer recognized by the computer. I have tried with just the camera and it makes no difference. I have to disconnect the camera restart the tower and plug the camera back in before the computer comes back on otherwise it won’t recognize it. The camera is USB 3.0 and that motherboard does have USB 3.0 ports on it. I am not sure if it is the old hardware that is causing this issue or if it is Ubuntu itself. I am looking at building myself a new main workstation tower AMD 3970X and I would like to get rid of windows other than just a vm for 2 of my programs that I can’t run on Linux. But this would be a show stopper if I can’t get it to work.

The webcam doesn’t show up in cheese I did it to work in guvcview for a little but that program also locked up after a little.

Does anyone have any ideas on what’s going on? I’ll try just about anything I can.

  1. Try the latest version of Ubuntu (Eoan Ermine) and see if it helps.
  2. Could you share with us the segment of dmesg --human just before the freezing occurs, probably all the way until shutdown?
  3. Could you share with us the temporaly same snippet of journalctl --catalog --boot?
  4. If you want, you can first get the camera in that flickering state and share the logs from that point onward?
  5. Did you try the camera on another computer with Ubuntu Bionic?

Good luck!

Thanks for getting back to me.

  1. I haven’t tried the latest Ubuntu I usually try to stick with the LTS versions because they are usually the most stable.
    a. But I can put it on a flash drive and try it out.

  2. &3 I will have to google how to do that and once I do I will definitely share that with you.

  3. I can get it to flicker every time so I will do that.

  4. I have not tired it on another Ubuntu Machine. I don’t have any other spare machines that are available.
    a. I can do a live boot of a USB on my workstation which is a dual Xeon machine. And see if that changes anything I could use a VM but I don’t know if I’d get the same results.

Any time.

  1. Yeah, do that.
    For what it’s worth, I haven’t had any stability issues using Arch with the testing repositories, let alone just using a newer version of Ubuntu. The only stability issues I’ve ever had are on Gentoo, but that’s using these GCC flags and only in a few programs: COMMON_FLAGS="-O3 -march=bdver4 -pipe -pthread -fira-hoist-pressure -fira-loop-pressure -fbranch-target-load-optimize -fweb -ftracer -fsched2-use-superblocks -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=2 -fuse-linker-plugin -fuse-ld=bfd -Wall -Wextra". Some flags are from GentooLTO.

  2. Just run the commands, they will show the logs (run man dmesg and man journalctl if you need any further clarification), and copy the log segments which are relevant, as outlined previously.

  3. All right.

  4. Can’t hurt to try.

Good luck!

Thanks for your help.

I’ll try and run these in the next few days.

1 Like