LM18 installation on Dell Inspiron 14 3452

Alright! It's been a long and tedious night. I have an issue. I recently bought an Inspiron 14 3000 series notebook from Dell. Normally, doing something as simple as installing Linux (Mint in this case) takes about 15 minutes at maximum for me. Unfortunately, this doesn't seem to be the case this time. The notebook that I am using has a 32GB eMMC drive as its primary storage and has no secondary storage device. once again, usually not an issue. The problem is with the BIOS(UEFI) that Dell has installed on the system. Dell's BIOS is locked in some sort I believe. I've disabled secure boot and disabled the Windows Boot Partition as it no longer exists. The issue I run into, is that ooting in UEFI mode, the system recognizes no bootloader being present. Booting in Legacy BIOS mode, the system does not list the eMMC storage device as an option? I've tried setting it to Hard Disk, USB Storage, and even Diskette. Nothing seems to be working. So, I launched the installation media to see if the OS i had installed was present at all, and it said that it was properly installed onto the system. So why can't I boot into it? How do I fix this? Any help would be greatly appreciated. (PS, Dell's documentation is so out of date online, I'd have better luck slamming my head on the keys for an answer)

Should I post this on LM forums?

You shouldn't need to disable boot partitions, grub will overwrite them if you install it in the correct place.

Is the eMMC the only storage? Maybe Mint isn't installing it in the correct place.

I'm not overly familiar with the inner working of UEFI boot loader stuff, so my only immediate suggestion would be to try a non Ubuntu based OS and see if there is any difference.

1 Like

Hmm, that's a good point. Hardware-wise the eMMC device is the only thing in there, but for some reason in the install, it lists 3 identical eMMC devices? It could be possible each device is on a different level? One software, one hardware, and one mixed? But only the hardware recognized listing is valid? I'll try to install the OS onto the next listing of the device. I thought it was simply an oversight or 'ghost' hardware that sometimes comes from removing devices after the devices are scanned. (I'll stop rambling and just try it... I'll write a book before I realize I'm wasting time instead of getting results :3 )

Are they three devices, or three partitions?

1 Like

Well, it's one device and only one partition. But in the install, it shows the same device and capacity (31.3GB) three times. It lists them similarly to sda0 -sda1 -sda2 but there's only the one device. It shows three, but there aren't three... I'm really confused.

sda0,1,2 are partitions, Does your live disk have gparted or gnome-disks? this will show more accurately whats going on.

1 Like

Really they are? Well, that's interesting. No, it doesn't unfortunately, but I'll get on that. That makes a lot more sense. I wonder, if there are three partitions on one disk, that means that I probably have a lot more storage than listed and that it was locked by the OEM.

Fedora has gnome-disks also sysrescuecd has a bunch of tools preinstalled. Its easy enough to install gparted or gnome-disks on the live disk for use as well.

You can also run lsblk on the command line.

1 Like

Well you could if you wanted to. A lot of linux mint users are pretty incompetent, and I say that lightly. I know its taken over as the most used distro with ubuntu behind it but it has a lot of flaws in my opinion.

If you think the problem is in BIOS settings, go in and turn of "Secure Boot", set it to AHCI in HDD settings, and turn on legacy boot (if theres an option. Sometimes turning secure boot turns legacy boot on too).

1 Like

I've tried that. It hasn't changed anything unfortunately.

Well fuck I dunno then lol on all my machines I have made sure I have BIOS so I can stretch it out as long as possible.

1 Like

Well, I just found out what the issue is... The eMMC drive is seen as an SD card by the system...

USe Manjaro then. I know it can see EMMC in 4.4. Update to kernel 4.7 and you shouldn't have a problem (in the settings is a kernel manager, no worries).

1 Like

I take it Mint doesn't recognize SD?

Its possible that its to out of date, or the installer cant recognise it properly to install the correct things.

If its a kernel/hardware/installer issue, any modern up to date distro should work well. Fedora, Arch based, openSUSE (should but not sure)

1 Like

sorry did not read the post properly...did not realize you actually managed to install the OS correctly. I suggest using boot-repair with the installation media...It usually fixes most of such issues.

EDIT: https://help.ubuntu.com/community/Boot-Repair

2nd option

1 Like