Return to Level1Techs.com

Linux Vega 56 never goes beyond state 1

I switched from windows to Pop OS 6 months ago and have not looked back since.
But recently i bought a Vega 56 and been somewhat disappointed when it comes to the performance of the card.
It struggles to keep just 60 fps in fallout 4 and Hitman. And in csgo im between 70 and 140 fps.
In Wattman GTK i can see that of the 7 gpu states, it rarely leaves state 0, and then just for a short period to state 1. I have never seen it go beyond state 1 under linux in any game.

So I installed Windows 10, and did the same test in csgo same settings, and after changing from balanced to turbo (i think it was called), my fps increased by 100 from low to max, so now i was sitting between 170 to 240 fps instead.

I have tried undervolting via Wattman GTK but to no avail, im still stuck at 0, and i cant seem to find anyway of changing from balanced to turbo in linux, and my searches for fixes always leads to undervolting.

Anyone know how to get this card to perform as it should under linux?

MORE INFO:
So i just bought 2 games, Hellblade: Senua’s Sacrifice and Kingdom Come deliverance.
The first of the two, performs just perfect, and the gpu acts as expected, first time in Linux i have seen it in the max states, for both gpu and gpu memory.
The second however is the worst performance so far, barely 15-17 fps on max settings, and the same states as with other games.
Looks like there is no other choice than going back to Windows :frowning:

Well, hi there.

I guess before anyone can even try to help you, a bit more information is needed. Like full hardware specs, BIOS version, OS version, kernel version, temps, clocks, … all the things, basically.

Other than that I can only say that this exists but I have not tried it.

Thanks for the reply.
Specs:
Amd Ryzen 5 2600, running at stock clock 3.4 GHz.
ASRock B450 Pro 4, updated to latest recommended bios version for my cpu: 3.50.
G.Skill Aegic CL16 DDR4 PC3000, 2x8gb
Gigabyte Radeon Vega 56 GAMING OC 8Gb, running at stock clock
Kingston SSD A400 480GB
SanDisk SSD Ultra 3D 500GB
Seagate Desktop HDD ST1000DM003 1TB

Clocks for the gpu have 7 states ranging from 852 up to 1590 MHz, these are the stock clocks.
Memory from 167 up to 800MHz also stock.

Distro: Pop!_OS 19.10
Linux version 5.3.0-7625-generic ([email protected])

Temps:
Idle:
|amdgpu/fan1|Fan|1171.00RPM|
|amdgpu/temp1|Temperature|47.00°C|
|amdgpu/temp2|Temperature|48.00°C|
|amdgpu/temp3|Temperature|48.00°C|
|amdgpu/in0|Voltage|0.75V|
|k10temp/temp1|Temperature|43.25°C|
|k10temp/temp2|Temperature|43.25°C|

Running Hellblade: Senua’s Sacrifice:
1080p highest settings
|amdgpu/fan1|Fan|1597.00RPM|
|amdgpu/temp1|Temperature|67.00°C|
|amdgpu/temp2|Temperature|74.00°C|
|amdgpu/temp3|Temperature|67.00°C|
|amdgpu/in0|Voltage|1.01V|
|k10temp/temp1|Temperature|61.50°C|
|k10temp/temp2|Temperature|61.50°C|

In this game gpu runs in states 6 (1538 MHz) and 7 (1590), with occasionally drops to 0 (852MHz).
Memory in states 2 (700 Mhz) and 3 (800 MHz)

Running Kingdom Come Deliverance:
1080p Ultra high settings
|amdgpu/fan1|Fan|1138.00RPM|
|amdgpu/temp1|Temperature|52.00°C|
|amdgpu/temp2|Temperature|55.00°C|
|amdgpu/temp3|Temperature|53.00°C|
|amdgpu/in0|Voltage|0.82V|
|k10temp/temp1|Temperature|61.38°C|
|k10temp/temp2|Temperature|61.38°C|

In this game gpu runs in states 0 (852 MHz) and 1 (991 MHz).
Memory only in state 0 (167 Mhz).

Ill have a look at the link to see if there is any thing i should have missed.

Maybe there is still desktop compositing going on? I had that on my system, the moment I turned that off I got way better fps and everything felt instantly more responsive. I just don’t know how to do that in anything but KDE.

You could also turn down settings to super low and see if the fps goes way up or just a little. That would at least indicate that the GPU isn’t the real issue.

I installed Gamemode, and that seems to have done the trick, at least in Kingdom Come.
I have yet to try out other games.

Thank you for your time and help noenken