Linux PC Unable to shutdown

Hey guys, new around here but i follow the YT channel quite often. Hoping I can get some help here as neither reddit nor distro specific forums have provided me with a solution.

Now I am by no means a linux pro although I have been involved with monitoring a linux infrastructure in my days working at a Govt DC. I got fed up dealing with windows pulling crap and switched my personal PC to Linux 2 months ago and adjusted quite well. However there is one issue that drives me up the wall - My PC will NEVER shutdown.

I tried ubuntu, Linux Mint and Manjaro both live and fresh installs and all fail to shutdown. I am currently running on LM Tessa Cinnamon and plan to settle on this distro if I sort out the shutdown issue.

Everyone points me to set acpi=force but this does not solve the problem, I found someone else who suggested apm=power_off but again did not sort out the issue had suggestions to turn on secure boot (no luck), switch off fast boot, reset bios, change from nouveau nvidia drivers to prioprietary (currently running 390)

Currently /etc/default/grub looks as follows:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off intel_iommu=on"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I’m not sure what’s causing the issue and where to look. If I sort out this issue I’ll convert full time but If I can’t get this sorted I’m afraid I’ll have to revert back to windows :frowning:

I’m running on the following specs:
i7 4790K
Asrock Z97 pro4
16GB DDR3 Ram
1TB WD Blue M.2 SSD (OS Drive)
256gb Samsung 850 Evo SSD
2x1TB Hard Drives

Does it not shutdown or does it just take a really long time?

What happens when you shutdown? Do you have pictures? Can you give more detail?

I had very similar hardware to you, only difference was the Motherboard, and I had the exact same problem. But, when I waited 2:30 to 5:00 minutes the computer would shutdown. I found it was GDM or another process unable to quit properly.

When I was using Fedora, I also noticed that when you click shutdown in the GNOME menu, the system sometimes just does nothing in response to it for a good 30s-1min. It’s really frustrating.

What’s it like when you shutdown via terminal?

sudo shutdown -h now
1 Like

On linux mint - I get the LM shutdown logo with the 4 dots below that keep cycling

on Manjaro - I get shown the ASROCK logo and get stuck there.

Can’t press ESC to view the shutdown log as the keyboard is the first thing that gets switched off. It doesn’t shutdown at all. As in - I’ll shutdown the PC for the night and in the morning it’s still stuck on the LM shutdown screen (Thankfully it didn’t burn in on my monitors)

I’ll try to get more details when I’m home

@Dynamic_Gravity will try this as well and report back

1 Like

Try one of the function keys F11 or F12 and see if you can see what’s happening “behind the scenes”.

So I ran

sudo shutdown -h now

and pressed F11, Here’s what I get:

At this point It just keeps showing the same message over and over.

1 Like

the last part of the message is telling you what is wrong ( for some reason the shutdown process appears corrupted).
save this info and check with the people on the mint forum and ubuntu forum.
between this info and the list of your hardware they should be able to sort it out.

in the mean time hard shutdown ( hold the power button in until the system turns off)
the next time you start the system fun fsck in terminal (this should locate the damaged files and possibly fix them)