Linux on an old thinkpad: why is linux trying to reset a disk that's not there?

Hey everyone,
I installed arch linux on an old ibm thinkpad t43 and every time i boot the machine i get the following (from dmesg):

[ 1.823936] ata1: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0x18c0 irq 14
[ 1.823941] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x18c8 irq 15
[ 1.893369] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0xb80ba9702b, max_idle_ns: 440795239054 ns
[ 2.019343] ata2.00: ATA-8: KINGSTON SV300S37A120G, 505ABBF1, max UDMA/133
[ 2.019349] ata2.00: 234441648 sectors, multi 16: LBA48 NCQ (depth 0/1)
[ 2.043925] ata2.00: configured for UDMA/100
[ 2.133462] usb 4-2: new full-speed USB device number 2 using uhci_hcd
[ 3.863448] random: fast init done
[ 6.866701] ata1: link is slow to respond, please be patient (ready=0)
[ 11.853463] ata1: device not ready (errno=-16), forcing hardreset
[ 17.053464] ata1: link is slow to respond, please be patient (ready=0)
[ 21.870073] ata1: SRST failed (errno=-16)
[ 27.070173] ata1: link is slow to respond, please be patient (ready=0)
[ 31.886841] ata1: SRST failed (errno=-16)
[ 37.086840] ata1: link is slow to respond, please be patient (ready=0)
[ 66.893478] ata1: SRST failed (errno=-16)
[ 71.923479] ata1: SRST failed (errno=-16)
[ 71.935093] ata1: reset failed, giving up
[ 71.949382] scsi 1:0:0:0: Direct-Access ATA KINGSTON SV300S3 BBF1 PQ: 0 ANSI: 5
[ 71.975674] sd 1:0:0:0: [sda] 234441648 512-byte logical blocks: (120 GB/112 GiB)

This slows boot time a lot.
What i found after googling was that the message occurs when drives are failing or the jumpers are not set properly (on ide drives), the problem with this is that in my computer there's only one drive (an ssd connected on the ultrabay via a sata adapter) and that is labeled ata2 by the system, there's also a slot for an old IDE drive but it's empty.

[ 2.019343] ata2.00: ATA-8: KINGSTON SV300S37A120G, 505ABBF1, max UDMA/133

i am also positive that the connected disk is not the problem because i also get the same message (ata1: SRST failed) when i boot from a usb drive with this disk removed (the distro in this case was the latest lubuntu)

i've already tried booting with various libata.force parameters from Kernel parameters (libata.force=1.00:disable, libata.force=nosrst, libata.force=norst, etc..)

the other suggestion i found on a forum (don't remember which one though) was to patch the kernel to ignore the device but i don't know how to do this.

as far as the cause of the problem my only guess is that it is caused by the sata to ide converter that the computer uses.

Thanks for reading.

I don't know your particular TP, but maybe you can deactivate the port in the bios completely?

Unfortunately there is no such option in the bios.


in case someone else has this issue, i found two solutions to this problem
At first i just gave up trying linux distros and installed netBSD and later freeBSD, both of these worked flawlessly on the old machine and don't complain at all.
but i really wanted linux so i turned out to hardware modifications, turns out that i just had to cut the sata lines going to the Marvell 88SA8040 PATA-to-SATA bridge chip as this guide says. (just cutting the lines removes the errors, but you could also use these to connect a sata drive)
after booting linux from a usb drive the errors were gone.


Are you going to try connecting a SATA port on it then? Everyone loves a good DIY post :)

I was about to do it, but I'm afraid I will break something as I don't have experience soldering really tiny things, the guide on my last comment already shows how to do it.

1 Like

i tried to do it and killed it :sob:
i guess the project now is putting a raspberry pi inside it :slight_smile:, just need to find a way to plug the keyboard and a controller board for the lcd

I am sorry to hear that - which components near the SATAtoIDE did you damage or kill? it may be still fixable - can you make a high rez image?

quite sure at least a smd capacitor. here's a before and after.

mhm - not so much to actually see in detail - but the cap alone mostly does not stop it from booting at all - never the less - a raspberry inside the case sounds like a great project too =)

Nooo, now I am sorry :frowning: That is how one learns I guess, trial and error :confused:

1 Like