Linux noob needs help! [SOLVED]

I've tried googleing a solution for this but nothing comes up. Basically the terminal in Ubuntu gives an error when I input a pipe command ( this -> | ). Anyone knows how to fix this?

why are you typing <iface> ???

I'm following a tutorial on setting up a lamp stack, and this command is in there.

ok, gotcha.

<iface> means "put interface name here"

If you type "ifconfig" it'll print a list of your interfaces. Then, use one of their names to only display info on that interface.

1 Like

You need to use an actual interface name instead of <iface>. Without <>.
To list all interfaces, use ifconfig -a or ip addr.

1 Like

Oh..I see, makes sense. I'm such a noob XD I now used enp1s0 instead of and it worked fine. Thanks for your prompt help!

1 Like

Free information: man ifconfig or ifconfig -h same as ifconfig --help Works on almost all commando's you use in the terminal.

man is short for manual and almost all mayor distribution have those installed, its not always there. The -h and --help always work if the software was programmed well enough.

<.Iface.> thats your problem, it's usually something like eth0-n or wlan0-n etc etc(unless you're using a new release of ubuntu they really borked it up).
try "cat /etc/network/interfaces"
It should give you a list of available interfaces.
What you are trying to do is list network configuartion, and parse out the lines with Mask in them, but since i syntactically wrong it tosses you a exception.
without bothering to try it ill bet you that ifconfig AHorseIsAHorseOfrouceOfCourse | grep Mask would give you no result, but no exception besides it didn't find the interface.

Learn the command first before copy pasting. There are lots of command line helpers you can install. I will give you links to some of them

You can use the 'man' command if you want a quick help on how the command works and its use cases.