Linux networking gurus pls halp

Hey all, I have a Panasonic Toughbook with Kali Linux on it. I have since October, and it has been just fine. Recently the wireless networking has been acting up. It seems to be connected, and then after loading 1-2 pages things start timing out. Seems to be DNS related. I have noticed that if I ping (Canadian, eh) the ip changes between (
and (

if I try to start a ping during the time where I cant load pages, It will usually fail with unknown host, though if I keep a ping running and don't control-c it, it will keep going with 0 dropped packets. If I try a wget to something like, it will make connection but the http request times out.

meanwhile my USB wireless adapter and wired both work fine.

I am letting network-manager control all my networking related stuff and have tried both the 5ghz band and the 2.4ghz band networks.( and I've tried forgetting them and reconnecting as well)

Any Ideas?

Supplemental information from lspci 0b:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

The actual DNS may be having intermitten issues; this does happen. Try changing your defualt DNS to something else, like OpenDNS.

Or go into terminal and force the DNS entries:

Update: Problem still exists. I have uninstalled network-manager-gnome, and everything that has network-manager in the name because it wasn't propagating my DNS configurations in the GUI into the configuration files. I deleted /etc/network/interfaces and started from scratch. It seems to connect to WLAN just fine and does a DHCPDISCOVER and gets assigned an ip properly. I logged into the router configuration on another machine and deleted the lease in order to confirm that it would actually negotiate a new lease correctly. It did change from to .18 so that is working. Still no HTTP requests go through though. apt-get update hangs at [Waiting for headers] wget makes connection, but no transfer.

I did notice that when I dmesg I get tons and tons and tons of IPv6 duplicate address warnings however, and I thought this might be the problem.

After plugging in a USB wireless adapter and editing the wlan0 in /etc/network/interface to wlan1, everything works fine.

the ONLY thing I changed was those 2 0's to 1's and everything works fine.
I still do get those IPv6 warnings (of course now with wlan1: instead of wlan0:) but it does not affect my network connectivity.

Does anyone know where there might be a configuration file that is nerfing specifically the onboard wireless in a way where pings works ( including outside network like but HTTP requests don't work. ( can't even browse to to view router configuration)

Could the wireless card be dying?

I used ifconfig wlan0 del inet6 (address) to delete the ipv6 address that was causing the warnings. The warnings stopped but connectivity did not improve. Furthermore, the address came back on its own, and so did the warnings.

What version of Kali are you running?

uname -a
Linux Toughbook 4.0.0-kali1-amd64 #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux

I've come home from university now for the summer and it works fine on this network. I think ipv6 is turned off on this router. It is running dd-wrt. The one provided by rogers has no provision for turning off ipv6