Return to Level1Techs.com

Linux Mint on a MSI GL62M

This is my first time installing Mint on a laptop with a GPU. Everything installed fine(or so I thought) but I’m getting extremely nasty screen tearing. In my research before posting, the “forced pipeline” setting in Nvidia server should fix the problem, but it’s missing. Does anyone know of a fix or some insight on how to fix this?

Did you install the official NVidia driver or are you using Nouveau?

Did you click advanced?

The official driver.

Yes, but nothing changed. The option never showed up.

can you post a screenshot of the tool you’re using?

As soon as I get home from work I will.

This is what I get after clicking advanced.

That’s out of my wheel house. I don’t use NV.

Which version of mint are you using?

Mint 20, 440.1 Nvidia driver, and X Server ver 11.

check that /lib/modprobe.d/nvidia-kms.conf exists and that it says options nvidia-drm modeset=1

if it doesnt exist, create it, and put that line in there
if it does exist, but modeset is 0, change it to 1

then do sudo update-initramfs -u

1 Like

IT WORKED! X Server now shows Synchronization as on.

2 Likes

cool