Linux Mint LTS, VMWare Workstation, & USB sound issue

Hello,
I have a issue with my Plantronics Savi 720 headset that I need to use with a Windows 10 VM that runs on VMWare workstation 15 pro, that runs on top of Linux mint 19.1 cinnamon. All software is patched and the kernel is 4.15.0-54-generic.
The issue is that while the Windows 10 VM sees the Plantronics Savi 720 headset and I have it specifically associated with this VM in VMWare workstation, the microphone is not picked up when I use Skype, but the speaker in the headset seems to work fine. Another curiosity is that the Windows Plantronics software to control this headset, does not see it at all.

One symptom that I noticed is that the headset link to the wireless headset only becomes active when there is sound that the Windows 10 VM wants to play to the wireless headset, then it disconnects when done.

Everything else on the computer in and out of VMWare workstation 15 Pro works flawlessly

I suspect that the issue is that Linux is dynamically giving and taking away the Plantronics USB on an ‘as needed’ basis with the Windows 10 VM. The Plantronics sound in the headset seems to follow my mouse in and out of the different VMs and also with Linux Mint itself.

What I would really like to do somehow is to do a hard ‘nailed up’ permanent association of the Plantronics headset to this specific Windows 10 VM so the Plantronics software can see it permanently ‘wired’ to the VM.

In VMWare workstation, I have already changed the sound card settings from “AutoDetect” to picking the Plantronics Savi 720 headset specifically in that drop down list, but that does not help.
I suspect that what I need to go with that setting in VMWare, is a similar setting in Linux Mint to tell Mint not to un associate the Plantronics headset with VMWare, but I dont know how to do that or if that is even the likely issue.

Any help?

And in case you are wondering, I first tried to use VirtualBox, but the video performance was horrible. VMWare workstation video performance seems to leverage video card acceleration to some extent, so VirtualBox is not practical.

System information:
Gigabyte X470 AORUS ULTRA GAMING (latest bios)
AMD 2700 CPU
Radeon RX570 8GB
32GB Ram
1TB WD SSD
Host: john Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
Desktop: Cinnamon 4.0.10 wm: muffin dm: LightDM Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic

Forgot to mention that I am a relative Linux newbie (for reply context)

You’re using USB passthrough?

Can you share the output of lsusb? I want to make sure it’s not showing up as multiple devices.

Have you checked the device manager and windows audio config to see if it shows up in there?

This is probably part of why. I’ve got a feeling there’s something going on with split devices or something. Some of these enterprise-grade devices do really dumb things with the USB tree, like have an internal hub that splits the devices off into two.

Hmmm, I’m not personally familiar with VMWare, but I can take a crack at it, or see if I can get someone who knows more. I’d imagine that’s possible. (it works in virt-manager)

1 Like

Thank you for the help sgtawesomesauce!

Windows does not specificaly see the Plantronics Savi 720, it only shows what appears to be a generic driver called “High Definition Audio Device”, and the Plantronics is not shown as an option to switch away from the current driver listed.

I am not familiar on how to setup ‘USB passthrough’. I understand the principle of what IOMMU is with respect to video passthrough thanks to Wendel’s videos, not sure how that would be setup with USB.

[email protected]:~$ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 002: ID 0c45:7603 Microdia
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 047f:ac01 Plantronics, Inc. Savi 7xx
Bus 001 Device 002: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse

NOTE: I tried to update the Linux kernel to the latest 5.x to see if that would resovle the issue, but it had no effect. I will likely change back to the previous LTS kernel later today of 4.15.0-xx.

sgtawesomesauce,

Seeing the output of ‘lsusb’ above, I moved the Plantronics USB connnection so it would be on a unique hub number. This did not change anything posative or negative. However, I suspect that it might be a required step for the ‘usb passthrough’ process that I suspect you will recomend next.

[email protected]:~$ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 003: ID 047f:ac01 Plantronics, Inc. Savi 7xx
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 0c45:7603 Microdia
Bus 001 Device 002: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[email protected]:~$

not sure if my reply posts were to your reply or if i accidently put them in a seperate, so adding this reply to hopefully notify you of the data you asked for. :slight_smile:

Looks like there is only one device. This will make life easier.

Regarding usb passthrough, it’s the process of attaching a USB device to the VM. How are you attaching the headset to your VM?

If you need help, this guide should help:

I have done these steps and no luck. At this point I a have turned in the issue to Plantronics and will also turn it in to VMWare later today when i register my licence key for VMWare workstation pro 15, as it is supposed to come with 30 or 60 days of support from the time its registered.
Thank you for trying to assist :slight_smile: