Return to Level1Techs.com

Linux MInt forcing itself unto Software render mode and Proton doeasn't work

helpdesk
amdgpu

#1

I installed mesa and kernel 4.15 on my system, but Mint keeps saying that hardware acceleration is not present. And I’m pretty sure that the reason behind it is the same behind the fact that games like Monster Hunter world don’t work through steam play. Any help?


#2

I recently updated my Linux kernel on Mint and experienced this issue. For me the fix was to remove and reinstall Nvidia drivers.


#3

I concur with @Cobra92fs. You need the Nvidia 415 series drivers which I am currently running on my Mint 19 system.

17%3A06%3A49-2018-12-03

Also one of the point releases of the 4.15 kernel (I forget which) is buggy. I am currently on the 4.19 series kernel and all is working well.


#4

Unfortunately, I’ve got an RX 480


#5

I would suggest installing the ukuu kernel update utility (just for ease of use) and going to the latest 4.19 kernel version.


#6

I am on 4.19 now


#7

Any joy?


#8

Nope, unfortunately…I think I’m going to reinstall it,


#9

Before you do have installed the latest AMD drivers?

https://www.amd.com/en/support/graphics/radeon-400-series/radeon-rx-400-series/radeon-rx-480

I don’t know what the options are inside the OS, not having used an AMD GPU.


#10

The reason why is cause it’s not detecting your GPU firmware. You have to install / enable your GPU drivers, whether it be AMDGPU, or the proprietary Nvidia software


#11

@Utopanic More than likely, you do not have all of the required pieces. You need to be running the correct firmware for kernel, LLVM, mesa, and amdgpu combo that you have.
https://wiki.archlinux.org/index.php/AMDGPU

Lastly, everyone in the AMD non-Vega camp is having issues with 4.19. There is a patch in upstream for 19.3 but that has not been released on any Distro that I know of. You need to disable dpm and/or dc. If you are using sound through HDMI or FreeSync, you need DC on.

Try adding amdgpu.dpm=0 to your kernel parameters. If that does not work, add amdgpu.dc=0 as well.

I am on GCN 1.1 so I can get away with that. Since you are on RX, you may not.