Linux installing but not booting after. Odd and extremely frustrating problem

Been trying to install Linux on to an old system of mine today.
Here are the system specs:
Processor: AMD FX8350
MB: ASROCK 990FX killer (not the 3.1)
RAM: 32G DDR3 1600
GPU: GTX980 ASUS STRIX
HD: 512G some Samsung M.2
Yes this MB does support M.2
Spec sheet here:
https://www.asrock.com/mb/AMD/Fatal1ty%20990FX%20Killer/

So what the problem is each time I go to install Linux no matter what the distro is except for Ubuntu GNOME. After the install when the system restarts I always get this message:
“Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key”

Now I’ve tried this with several distributions. They are as follows:
Linux Mint Cinnimon
Ubuntu Studio
Manjaro
Fedora
Ubuntu Mate
Ubuntu Gnome
Xbuntu

The only one that works on that list is Ubuntu Gnome.
Here comes the other part of my issue I also tried to set up Ubuntu with the low-latency kernel because I’m trying to utilize this system for some audio work. But every time I’ve tried to use that (I.E. enter into terminal: sudo apt-get install linux-lowlatency) The system locks up.

Now I’ve tried poking around in the UEFI to disable secure boot, because on an old laptop that gave me issues installing Linux before but aside from that I have no idea what could be going on. I also tried updating my MB firmware thinking that might help but I also found out that this MB isn’t finding the web address to get the new firmware, and it can’t see the USB stick that I have the firmware uploaded to. (NO I did not have the Linux installation media plugged into the system when trying to upload the firmware.)

Another thing I’ve tried is making the bootable usb stick in different software (IE Ruffus unetbootin and Universal-USB-Installer).
Also I tried making the bootable usb installer on my linux laptop using DD.

I don’t know what the issue could be with all of this. Sorry about the length but I figured the more details the better.
Thanks,
Dan

Sounds like you have multiple problems. It might help if you edit your thread tittle to be little bit more descriptive, to tell others right away what is the problem.

About boot issue, does this AMD platform support M.2 drives? Tried to google your motherboard and didn’t see any M.2 connectors, so how the boot drive is connected? If you have any regular SATA drives available try using one as boot drive and see if that fixes the problem.

I also added helpdesk -tag to your thread.

I edited the post to Include the spec sheet for the MB.
Yes it does support M.2 but I suspect that its probably passing it through the communication for it through SATA. Because the FX8350 is too old to probably handle such things. All I know is back when I first built this system before it became my old system, I loaded windows just fine off of this M.2, and after that Ubuntu Gnome. Now all I can get is Ubuntu Gnome on it.
Thanks,
Daniel Dunham.

I would assume that if you are having this many issues, there is probably something that you are not doing/missing.

So, you may need to make sure you have CSM/BIOS mode turned on instead of UEFI. If you are using UEFI, you need to make sure that the installation media supports booting into UEFI mode. I have not done a fresh install since 2014 ish so I would assume UEFI support is universal now, but double check.

Also, find your boot menu option and see what your boot options are. And lastly, what is the filesystem format that you are using?

I just recently had major problems with my PC, it wouldn’t boot windows at all but Linux was fine. Ended up having to do some crazy workarounds, involving enabling hotplugging on the sata port of my ssd drive, booting on to a separately created windows install on another drive, then Downloading and launching my ssd firmware manager to update the firmware and it fixed all my uefi issues.

are you using grub or systemd boot?

do you have secure boot enabled?

do you have UEFI?

Are you still having this problem or were you able to resolve it?
I have a almost identical rig laying around, same MB, CPU. I have had, Manjaro, openSUSE, Arch, Mint successfully installed and working.

Two things come to mind:

  1. After you install your OS, and reboot go into BIOS and make sure that the Boot priority is set correctly. I had a situation where I installed a OS (don’t remember which) and the BIOS somehow configured it self to boot from openSUSE that did not exist anymore, that lead to failure to boot.

  2. Try a HDD/SSD if you have one laying around instead of trying to boot of the M.2 <-- this is your most likely culprit IMO.

That should not be happening…
What PSU are you running?
Is there any Overclock applied to CPU? I would pull all components out (RAM, GPU etc.) blow some compressed air into the sockets and re-seat everything.
If none of these help, reset the cmos and try again.

I cannot begin to tell you how much crap this Mobo put me through when It was my main rig…
Feel free to post your BIOS config, ill compare it and see if anything jumps at me.

Do antique AM3 boards even support UEFI? I deployed a number of Phenom II systems and none of them had UEFI support. Even if they do, this doesn’t prevent you from installing Linux in BIOS/MBR mode, if for some reason Secure Boot can not be disabled.
Be aware that M.2 support and M.2 boot support are two very different things, so I would look into that.
When asked where to put grub, select the desired boot drive, not a specific boot partition.

m.2 didn’t really pop up back in the “olden days” when the 8350 was “mainstream”, if i were you id try and buy a nvme>sata adapter, and try and boot of that. else before anything just try a regular sata harddrive, and check if that runs stable, any drive would do really, it is just a “does it run” test.
My guess is that some genius found a semi way of nvme working on these old chipsets, and if none of the above works, try the very newest driver versions for your mobo.
(point being because your hardware has a interface for it, doesn’t mean the software supports it).
i got a 8350 system running here and it runs flawless, even with a nifty overclock, and all that jazz i never had problems with stability, but it doesn’t run “new” tech just good ol sata/SSD’s and ddr3 memory.
only time i ever had problems was when i figured i’d try out a 4.5-5Ghz overclock(which obviously is a problem), on a 3.7 chip.

Yes, they did… a lot of them actually. I have at least 5-6 boards laying around that did support it. If I recall correctly UEFI became a standard in the industry around the time of release of FX4100 cpu’s.

This motherboard has a toggle for secure boot.

I second this, try to boot of a regular SATA SSD/HDD for the sake of testing.

I have looked into this, and there are people who have this setup booting windows from the NVMe drive, plus ZDunham1988 stated that he was able to boot off the NVMe drive under Ubuntu. But I have also found posts online regarding people having a hard time getting certain NVMe drives to boot from.

I also have this exact MOBO, unfortunately I don’t have any NVMe drives so I can’t test this for my self.

ZDunham1988 can you check what version of UEFI you have installed, are you on the latest 1.6?