Return to Level1Techs.com

Linux headphone jack issue

so I recently got a new laptop (matebook 13 2019) and naturally installed kubuntu on it, everything went super smooth until i noticed that the headphone port wasnt working and it ended up being an issue with it not detecting when a device was plugged in and was fixed quite easily by changing one line in a conf
(sudo echo “options snd_hda_intel model=dell-headset-multi” >> /etc/modprobe.d/alsa-base.conf)

but after a couple hours and 1 reboot later i noticed that the audio was no longer working when i plugged in headphones until i changed the microphone from “microphone” to either “internal microphone” or “headset microphone” which can be quite annoying every time i want to plug in some headphones and watch a youtube video. any help would be greatly appreciated :slight_smile: (also im fairly new to the linux community so please be gentle)

On mobile so bear with me. Seems like you should be able to change the default input device.
System Settings (the gear icon at the top right of the screen) -> (click) Sound -> (click) Input .
The highlighted option should be your system default.
C/P from here https://askubuntu.com/questions/1019798/how-to-change-default-microphone-configuration-on-ubuntu-16-04