Linux GRUB? Something is giving me headaches

So I have in my possession 9 PQI 128MB Disk On Module SSD's. We use these to house German DOS 6.22 and a custom program for controlling Automated Chain Hoists (You can probably YouTube VARIOLIFT and get an idea of the sillyness I'm up to.)

I got these drives off Ebay as it's the only place I can find them this small anymore.

It appears as though in their last tasking, they were loaded with a Linux OS and program to run machinery. I'm having a beast of a time undoing this.

I initially plugged them into my laptop via an external IDE hard drive enclosure. They didn't pop up in explorer nor could I find them via DOS commands. I ended up looking in the Disk Management window and located them there. They were partitioned into 122MB and 2 MB sections. I figured the easiest thing to do was delete the volumes, then do the long format back to FAT.

This worked as far as allowing me to finally gain access to them via Explorer, but when I put them into the computers we use for the control system I'm running into headaches.

The computer posts just fine then goes into "Verifying DMI Pool Data" after which it says: Bad Stage2 Loader Error.

I did a bit of Googling and have pretty much come up dry. The one semi-solution I found was to put an OS onto the drive in hopes of making this go away. So I popped in the first German MS-DOS disk and rebooted the computer. It allowed me into the installer and I successfully loaded DOS 6.22. However upon reboot, I get the same error again.

I've tried formatting the drive numerous times now, though it's always done from my laptop, as I can't get to a DOS prompt on the operating computers because of these issues.

A friend that's a programmer sent me a link to Windows' site about formatting the drive after saying it's a GRUB issue that I'm having. However the steps outlined there are all ones I've already tried.

Any idea how I can stop this problem?

---Everyone else's suggestion is "LOLOLOL DOS! Get a new computer dude! How LAME!!!!!!1!!11one!!" Not an option here folks. Custom software written in 1996 controlling a system via a protocol that went out of use in early 2000. Gotta keep this thing alive until I can finish the R&D for the new system. 

Download a GNU/Linux distro of your choice. OpenSuSE is very well supported in German language if that helps, but I would just download a Fedora 18 with Gnome 32-bit live disk, and run it as a live disk on your PC. Then attach the SSD's, open "Disks", and delete the partitions on the SSD, apply, reload, and then create a single new FAT partition, and very important, flag it as boot, and apply again.

Then try again.

If it doesn't work, let me know, and I'll post a link to a free Austrian program that will solve your problem the hard way.

The OS on the disk appears to be in English. Only reason I'm using German DOS is that according to the original manufacturer, the software doesn't run correctly on English DOS. Not sure why...

Giving your solution a shot, I'll let you know how it goes.  

Oh and by the way, you can buy a compactflash card, the pins of a compact flash card are the same as a small IDE connector, you can even plug in a compact flash card to a small IDE connector to substitute an old 1.8" laptop HDD with a compact flash card for instance. Compact flash cards can be had in 128 MB and are pretty cheap and very reliable.

Don't forget to run the SYS command from your DOS disk to copy the hidden system files to the SSD you load DOS on, or it will not boot in DOS. Probably unnecessary to mention this but your never know right.