Linux Gaming: My 360 controller doesn't work right when my PC wakes from suspend

Hi All,

I recently went on a distro hopping binge in an attempt to solve a problem with my wired 360 controller. Basically the controller works fine; only when the PC wakes up from Suspend, the central LED ring flashes continuously and the controller can't figure out which player it is. And because of this, then the controller doesnt' work on any of the games I've tested.

I initially discovered this problem because I wanted to experiment with a rolling distro (newer kernel, drivers, and software); I enjoyed the rapid development of the DE in KDE Neon and wanted the same experience at the base level of my OS.

My forrays into Arch, Manjaro, and OpenSuse all led me to this problem. And despite posting several times in their respective forums, the issue was not resolved. Installing all sorts of drivers, uninstalling all sorts of things, did nothing to resolve the issue.

After two weeks of distro hopping, and frustration, I threw my hands up and came full circle and came back to KDE Neon, where with its Ubuntu 16.04 base, running 4.4.0-64, the controller worked fine.

Just now, on a whim, while trying to resolve another issue with my distro, I decided to update the kernel (4.8.0-34). Lo and behold, now KDE Neon suffers from the same issue.

So, in all rolling releases I tried (all of which have a post 4.8 kernel), my controller didn't work properly. When the ONLY change I made to my OS was upgrading the kernel in KDE Neon, the controller stopped working.

So I'm fairly confident at this point, that somewhere between 4.4 and 4.8 a change was made that introduced this bug.

Naturally I want to get it fixed. How do I go about doing that exactly?

Or is my diagnosis incorrect, is there something else at play here? I'd love to hear some feedback

have you tried using the userspace xboxdrv package?

I'm not sure if I used the userpace xboxdrv package; but in Arch, I did try every permutation of drivers I could find: xpad, xboxdrv (not sure if that is the same as the userspace one youu're referring to), and steampad-os.

The problem is persistent on all drivers (however there is a chance that I might have installed them wrong).

To be honest I haven't owned one for ages now, I just remember that one being the best at the time

are you using joydev or the other gamepad input manager?

what does the output of jstest show?

does the gamepad appear in udev/the other one?


I'm sorry I should clarify that I'm not exactly the msot adept linux user.

You're right about the xboxdrv being the best at one time, but if you trace the source in the archi wiki back, it's a single blog post from 2011. I don't think that information is really relevant anymore.

1.) Joydev or other: I'm not sure what this asking exactly; I've only used default input managers. In KDE, under Settings --> Input Devices, there is a way to check the controller.

2.) I just tried installing jstest-gtk, but couldn't get it to work. So I'm going to defer again to KDE's settings. The inputs are registered just fine. But that isn't the problem, the PC is having trouble figuring out which controller/player it is. So in games, where it searches for player/input 1, the controller is useless at this point.

3.) I'm not sure what you're asking about udev. Can you expand on that?