Return to Level1Techs.com

Linux Freezes Windows Doesn't

Hello everyone for the past few months I’ve been having a problem with one of my desktop computer running Linux. I have Linux Mint installed on an ssd and windows 10 installed on a hard drive. The hard drive with windows works fine and doesn’t crash. Linux on the ssd crashes after the first 60 seconds the operating system boots up. I know it’s not the ssd now because I installed Windows on it and it works fine.

  • Had kernel 5.3 installed so tried going back to 4.15

  • Tried reinstalling the operating system

  • Tried Zorin OS and Ubuntu also

  • Tried switching the sata cables

  • Tried running a live boot from usb

  • CPU was overclocked and went back to base

So it basically seems as though the system is completely refusing linux, even on a live usb. Any ideas? Thanks

Specs:

Intel Core i5 2500-K
Asus P8Z77-V Deluxe (latest bios installed)
Geforce GTX 660 Ti
16 GB Corsair RAM DDR3
Samsung 256 GB SSD Evo

It shouldn’t make a difference but maybe try a non ubuntu based distro? Manjaro would be my goto for that.

Other idea, do you have a second GPU flying around? Anything non nvidia?

I don’t have another GPU around at the moment, but I’m going to give Manjaro a try.

What crashes exactly? Is it gnome, with an error message, or the kernel?
Can you access any other terminal sessions during a crash?
Like hold Ctl+Alt and tap F2 for a terminal login, in case it’s the desktop crashing?

The entire system freezes. Sometimes after about 60 seconds after bootup other times just random. I can’t move the mouse around or type anything. If audio is playing for example it cuts off after about 5-10 seconds after it crashes.

I was wondering if it might be a gnome3 thing, and if trying a different desktop might be worth a go?
Manjaro has like xfce and others as a option, might give them a go?

1 Like

Yeah, XFCE runs on everything. If that crashes, it’s not the DE.

1 Like

Does your board have onboard video, just for test?

I remember having this issue on my 2600k with Fedora (had a 660 ti at the time)

Let me see if I can look back through my notes to see if I can figure it out.

There’s a few things I’d do. First, is it a problem with the LiveCD or just with the installed OS? That should rule out hardware problems. (hopefully)

After that, I’d look at journalctl -b -1 to see if there’s anything interesting in there. That’ll load up the systemd journal from the previous boot. You can do this in a chroot env if you can’t get your system to remain stable for long enough.

Have you tested the SSD, to make sure it’s not failing? You should be able to run a SMART test on the LiveCD through the Gnome “disks” tool.

2 Likes

Would a chroot env be like, running a live USB session, and then mounting the SSD(with the install) onto a mount point to look at the logs on the SSD’s filesystem? Like dissecting a corpse

I ran a SMART test on the ssd with no resulting errors. Now I’ve had manjaro running on a usb stick for about 30 minutes and no errors have occured yet. @sgtawesomesauce I will keep manjaro running for a bit longer and after that I’ll reinstall Linux Mint (Ubuntu Based) on the ssd and after it crashes again I’ll take a look at what journalctl says

1 Like

It could also be GPU driver related, I’ll try switching between the open source drivers and the nvidia drivers.

1 Like

Hmm, interesting. :thinking:

Which were you originally using? The 660 Ti should work just fine with Open Source now. You’ll lose a little bit of performance, but on a GPU of that era, it shouldn’t be too noticeable, since nouveau has had plenty of time to mature.

I’m pretty sure I was using nvidia’s but just to be sure i am flashing Mint on a flash drive again and i’ll try running it only with the open source drivers.

That might do it.

So far with the open source drivers everything has been running smoothly, this did pop up for a little bit and it scared me a bit because when this happens is usually means everything is about to crash.

If it crashes again i’ll have to switch to something else because cinnamon runs with video hardware acceleration.

All this seems very strange though because I’ve been using Linux Mint on this system for a couple years with proprietary drivers but this issue has only occurred this month.

Hmmm.

I’m not a pro with GPUs, but that indicates a potential hardware issue. Maybe someone with more experience can chime in?

1 Like

That looks GPU related.

1 Like

Doesn’t your 2500k have an iGPU?

It does, I could try it out for testing purposes but I probably won’t use it as a long term solution because that would mean I’d have to switch between dedicated graphics to integrated every time I switch from Windows to Linux.

In Windows everything runs smooth as butter though!

Also thank you everyone for the advice so far!

2 Likes