Linux does not detect ssd. New build on X399

Built a new system using:
Asrock X399 Phantom Gaming 6
AMD Ryzen Threadripper 2920X
2x ADATA AGAMMIXS5-1TT-C (Identical NMVE ssds)

When installing linux (i have tried manjaro, fedora and MX) only one of the SSDs is found. This problem persists after finishing the install.

fdisk -l
dmesg | grep
or GParted
finds the harddrive.

When installing windows both drives are found and function as expected.

what does lsblk show?

check out this thread, seems to be something similar:

note this :

Half working.

I had PCI_M2 and PCI_M3 populated. I guess you have to have PCI_M1 otherwise you’re in for a bad time.

Ashamed i didnt find that in my googling. I’ll try switching NVME slots.

Changing NVME slots didnt change anything. Put one in the M1 slot and when that didnt work i tried switching the ssds between slots.
Still no trace of the 2nd drive in linux (including lsblk)

Note: In both cases i could boot into manjaro (on the one disk), but not see the other disk.

Do both drives getting detected in the bios?

Both drives are detected in BIOS

It both is and isnt a EFI issue at the same time…

@sela This is what I am looking at when I am talking your motherboards specifications before I continue!

**ASRock Ultra M.2**  (PCIe Gen3 x4 & SATA3) are the slots in question

* Slots

- 3 x PCI Express 3.0 x16 Slots (PCIE1/PCIE2/PCIE3: single at x16 (PCIE1); dual at x16 (PCIE1) / x16 (PCIE2); triple at x16 (PCIE1) / x16 (PCIE2) / x16 (PCIE3))*
- Supports AMD Quad CrossFireX™, 3-Way CrossFireX™ and CrossFireX™
- Supports NVIDIA® Quad SLI™, 3-Way SLI™ and SLI™
- 1 x M.2 Socket (Key E), supports type 2230 WiFi/BT module
- 15ÎĽ Gold Contact in VGA PCIe Slot (PCIE1, PCIE2 and PCIE3)

*Supports NVMe SSD as boot disks

* Storage

- 8 x SATA3 6.0 Gb/s Connectors, support RAID (RAID 0, RAID 1 and RAID 10), NCQ, AHCI and Hot Plug
- 1 x Ultra M.2 Socket (M2_1), supports M Key type 2230/2242/2260/2280/22110 M.2 PCI Express module up to Gen3 x4 (32 Gb/s)*
- 1 x Ultra M.2 Socket (M2_2), supports M Key type 2242/2260/2280 M.2 PCI Express module up to Gen3 x4 (32 Gb/s)*
- 1 x Ultra M.2 Socket (M2_3), supports M Key type 2230/2242/2260/2280 M.2 SATA3 6.0 Gb/s module and M.2 PCI Express module up to Gen3 x4 (32 Gb/s)*

*Supports NVMe SSD as boot disks
Supports ASRock U.2 Kit

Now it says supports NVMe SSD as boot disks… This is true but ONLY for the first Ultra M.2 slot first off according to the manual which does not explicitly state it in its entirety. Its rather kind of vague.

So lets begin with the fact in order to support NVMe boot the EFI must be able to talk with the controller on the NVMe disk through the interface. In some cases (usually cheaper SSDs) this does not always happen and it is why the manufacturer has stated a short list of COMPATIBLE NVMe SSDs for boot. Now doing a little investigating you cna find which controllers all of those use and there are a plethora more SSDs that use the chipset. From what I garner these ADATA SSDs actually are not on the supported list but they are using a supported controller and that is why you see only one on the Ultra M.2 M2_1 slot.

But this is also something that can be OS dependent. Sometimes the EFI can see both which means your controller is seeing it just fine. The issue is actually with the operating system and after some googling. I have found that Debian has no issue seeing it. Neither does Windows 10 (latest build) … OpenSUSE tumbleweed also would see it as well as Ubuntu 19.04 . Try these variants and see what happens first!

Also sometimes on certain EFI system the EFI restricts the ACPI calls of the system which can affect situations like these. Adding these to your grub parameters might also have an affect. You should test it

acpi_osi=windows 2015 acpi_enforce_resources=no

I suspect its kernel related to the kernel that ships with the image your using to install. I could be wrong but start here


I tried OpenSUSE tumbleweed as well as the extra grub parameters. No luck.

I am facing the fact that i am not ready for the linux challenge.

Hey dont despair man if nothing is working seriously try building a debian image with the latest kernel

If not just wait 6 months for the next release cycle of almost every distro…

Support should be ready then

Also TBH linux is already so fast perhaps you should just boot off a sata disk? Im really not sure what to do with limited information of what is actually occuring…

If you provide a full verbose printout of the following commands we can see whats up maybe.
Check for disks:
List PCI and PCIE devices:
Check if NVMe is built into the kernel
modinfo nvme
Look for nvme devices
lsmod | grep nvm