Linux Boot no display / Proxmox (or other hypervisors) or not?

So, I have two problems, one actual, and the other one in-concept.

First, is the fact that my new system refuses to start any linux OS up properly. I’m planning to use Manjaro, but I also tried with ubuntu as well. On both of them, any attempt to boot into the installer simply sends to a black screen. The odd thing is, this also happens to another system.

Both ISOs are started using Ventoy, but I did try just directly flashing it to the usb using balenca and rufus to no avail.

For both, when booting manjaro, both will display some [ok] stuff in the console, before going straight to a black screen.
On ubuntu, only safe mode graphics works, but clearly that’s not a long term solution. (I also don’t have my storage here yet, so I can’t install to a disk yet).

I have tried setting nomodeset, amdgpu.dc=1(or 0), CSM on and off, secure boot off (always). I’m just stuck. SVM, SR-IOV and Above 4G is also on, in case that matters.

The first system is on a 5950x, and has a 6600xt, and will have a 1070 as well.
The second is just a 4560g APU.

The 4560G is running as a TrueNas system, so I don’t exactly need to give it a head, but when I do, it also exhibits similar behaviour, where it just simply stops displaying. Thankfully, other stuff seem to be working.

So far, the only common thread is that both uses and AMD gpu.
For context, my other system which has the 1070 and a 3950x installed manjaro with no problems, as did my t580 thinkpad with an iGPU.


Second, is the Proxmox (or Unraid, I dunno) issue. Rather, I’m debating if I should run Manjaro and Windows under Proxmox, or just go straight Manjaro and then KVM Windows there. That will go on the 5950x system.

I know that apparently Proxmox is still using KVM, so there’s that, but it also runs with a web gui (or maybe not, not sure).

The reason for the two different GPUs is to allow the linux system the AMD one, since apparently AMD is better supported on linux, though NVIDIA recently has released some drivers as well, and the Nvidia one on the Windows VM for native games rather than running through a compatibility layer.
I’d want to stick with linux as much as possible, but frankly I’m just too much noob to linux to really want to spend all the time on getting a game working.

Any help on the two issues would be greatly appreciated.

@BlakeTech I am running KDE Neon (based on Ubuntu) on my Ryzen 5950x. The only difference between mine and yours is I have a Nividia 3060 graphic card, and you use AMD 6600xt. You might want to try Pop Os (based on Ubuntu). I have included a link from Pop Os that should download the correct Version of PoP os to use on your machine.

If you don’t want to spend a lot of time troubleshooting games and to try to set up KVM Virtual Machines, I suggest you either use the Ryzen 5950x as your Windows Machine or the Ryzen 3950x. Passing through a graphics card in Proxmox, Unraid, or using Linux Kernel Virtual Machine isn’t as easy as YouTube Video makes it seem. You will run into stumbling blocks and if you don’t want to spend a lot of your time troubleshooting them, then have one machine run Linux only the other machine Windows.

do you have pics of errors shown on monitors?
or any other errors that happen during boot?

I don’t have any pictures, but I have doubts that will help. A video might work better, and I can try to record some shaky hand footage for it.

But just as a text-based recount for now, all it does after selecting either open source drivers or proprietary ones, both outcomes are the same. it runs to either network manager or CUPS, then the screen goes black, and signal is lost. The system physically itself looks to be active, however, so I’m really inclined to suspect some sort of driver issue, but as stated in my initial post, I’ve tried a few common solutions that I found online, to no avail.

Actually, no. Partial lie. Nomodeset, iirc actually might have reached tty on Manjaro, but startx did not do anything on account of it reporting no screens found. Ubuntu, when running on safe mode, spat out vgacon disables amdgpu kernel modesetting.

I don’t want to use ubuntu, however. I know that technically, it’s all linux under the hood and it’s just different flavors, but my laptop already runs Manjaro fine. My existing desktop installed it fine. I highly suspect it’s something to do with amdgpu drivers, and I want to get it working. Plus, I like the idea of the updated kernels instead of the base OS itself needing constant updates, as it’s more similar to Windows in that regard. (Well, it was before they pulled this W11/W12 bs).

Also, I’m fine with spending time with setting up VMs. I like a challenge, and I don’t have the space to run two desktop rigs. As it is, I’ll be selling the 3950x system later on once I get the 5950x stuff running and migrated over to it. I also want to push myself to use linux more often, but I also need to retain the windows OS for other family members as well, and for the games I’d like to run, but that’d likely be all that it’s used for, and for that, I’m happy to spend the time to get it working.

Can you please try with this option, and in case you use it “Resizable Bar Support”, both turned off. I had Rocky Linux refuse to start with those set just days ago. I have no idea if this was a bug or expected behavior. Apart from that as @nx2l mentioned we would need something to actually diagnose the problem, otherwise it could be a million things.

@nx2l pinging you too since this may help.

https:// youtu.be/-oaAHYzlORQ
I can’t upload video here cause I’m too new.
…I also apparently can’t attach links either. How am I to ask for help and provide more information.
Just remove the space between the / and y.

2 Likes

Oh right. Turned off ReBar and A4G as well in that shitty handcam video. Same display error.

1 Like

Alright. Serious question, have you tried a different monitor as well as a different video output port and maybe even a different cable. Maybe it is just up to bad EDID data send from the screen or a bad/failed link negotiation between the card and the screen. It looks like the screen is giving out the very moment the driver would jump into action, set a new resolution to display the GUI and so on.

I… don’t have a different monitor to test with. It’s also running on HDMI, but I don’t think it’s a bad video out, since it happens to two different machines with different hardware, short of them being both AMD GPUs. The screen itself only has HDMI and VGA, and I’m currently using it on the main system over hdmi just fine, though a different cable. I can try switching that, I suppose.

…Fuck me, it was the HDMI cable. Never realized that it can be half-faulty, just enough to get past some but not all of it. Now I feel like an absolute twit. Thanks for solving that one.

Do you have any input in regards to the Proxmox/Unraid/KVM question too? Or should I make a new post on this?

2 Likes

Glad we figured it out.

In regards to the other question, if your only use-case is to have a virtual machine with GPU-passthrough you can use a simple Manjaro (or other distribution) installation and run a single VM for games and such. Proxmox and solutions like that shine if you plan to use a more complex setup with several VMs and maybe containerized applications. But I am maybe not the correct person to ask because I base all of the later examples on KVM virtualization in my machine as well.

1 Like

:+1: Right, so I’ll just go with the original plan of Manjaro as host OS, then KVM Passthrough a Windows system as well. Thanks again, has been a much faster and helpful response here than my attempt on Reddit.

1 Like

@BlakeTech, if the above statement is true, disregard my advice about two machines. I have uploaded your video to the forum for you, BlakeTech.

If you are set on Manjaro I will leave you with the link to the Arch wiki that nicely explains a lot of the things that one needs to, or can optionally, setup.