Return to Level1Techs.com

Linux and the RTX Cards

#1

So, this may just be isolated to my machine, but I don’t think it is. I for some reason, cannot get any distro to behave properly on my system with my RTX 2060 installed. I had openSUSE Tumbleweed working for a while but an update to either the kernel or the nvidia drivers broke it. I had wanted to move to something arch based for a while, and heard that Manjaro worked well with the newer nvidia cards. So I tried to install that, but was unable to even get the USB to boot. I tried removing the GPU, installing it, and then putting the GPU back in and installing the drivers. But it still just stops at the black screen.

I wouldn’t call myself a linux n00b. But I am by no means an expert, just a guy who prefers linux. I really hope someone can help me out. I’ve been having to use Windows 10 and I don’t like it. I want my Linux rig back!

0 Likes

#2

the RTX gpus should be compatible with linux. did you try nomodeset in your kernel cmdline options?

0 Likes

#3

I did try nomodeset, as well as the nonfree drivers where they apply.

0 Likes

#4

and it was working on opensuse?

0 Likes

#5

It was working just fine on openSUSE. Albeit a finicky boot process, but it worked fine after that. (it took a while to boot, like a solid minute or more on an SSD)

0 Likes

#6

did you try a snapper rollback before removing opensuse or did you just install manjaro straight away?

0 Likes

#7

I just installed manjaro, but not before trying all the options I had done to get it working the first time: reinstall drivers, use manual drivers, nomodeset, etc.

0 Likes

#8

is it just manjaro that doesn’t work? are you able to get to tty on manjaro or is the entire system unusable?

0 Likes

#9

I’ve been able to get tty on manjaro, I installed the drivers via mwhd. But that still just landed me at the black screen.

0 Likes

#10

black screen when you try to access your desktop?
look for errors in logs. things like the systemd journal for your display manager or Xorg log files in /var/log or dmesg

0 Likes

#11

I just get things like failed to start xorg.

0 Likes

#12

have you checked what driver is on the GPU using lspci or something?

0 Likes

#13

I did check that last night. It was installing 418 on there.

0 Likes

#14

what is the output of sudo lspci -k

0 Likes

#15

I’ll have to clarify, I’m not home right now. I’ll have to try tonight and get back to you.

0 Likes

#16

What you’re looking for in the output, when you get to it, is something like

01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
        Subsystem: Gigabyte Technology Co., Ltd Device 3667
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

As you can see, nouveau is listed under Kernel modules because I do not have the kernel module blacklisted. The important part is that nouveau is not Kernel driver in use: If nouveau IS the kernel driver in use, that means that despite installing the nvidia proprietary driver the incorrect driver is still being used. If nvidia is correctly the driver in use, that means the problem lies elsewhere.

1 Like

#17

I haven’t had the best luck with the RTX 2060 + the open drivers. The proprietary drivers work pretty well though.

1 Like

#22

Yeah, don’t use nouveau on RTX cards. If you need to force it off in order to boot, adding modprobe.blacklist=nouveau to the grub command line will help get you into an X11 session if you prefer to do things just in the GUI.

Also refer to the OpenSuse Wiki on setting up the proprietary driver via YaST or zypper.

https://en.opensuse.org/SDB:NVIDIA_drivers

Only mentioning this as sometimes using the the .run file from nvidia doesn’t go well, as it doesn’t grab any needed dependencies for lib32 support or DKMS. (build-essential, Kernel headers, etc.)

2 Likes

#23

I believe he is trying to use manjaro rather than opensuse

0 Likes

#24

Honestly, either are fine. Although manjaro seems like a better option. But I like openSUSE too. Whichever one runs the best/has the best compatibility with my GPU is really the determining factor here. I’ll be home in a couple hours to try some more things.

0 Likes