Lightdm gone,gdm gone, gnome shell gone, everything but the tty is gone

So I did a sudo apt-get dist-upgrade and a sudo apt-get upgrade...reboot and now, gnome and every gnome and unity application is gone, its now a barebones system.

proceed to make even more bad choices.

I removed lightdm, gdm, and kde, gnome-shell, and everything gnome related. in hopes to refix everytrhing.

Its now stuck in a samba start and stop phase on boot,
apt-get install ubuntu-desktop returns with literally everything from fire fox to natuilus being reccomended but not installed because unmet dependencies for libgl1-mesa-dri deppended libs are missing.

cant get gnome shell, cant repair packages, cant upgrade distro, cant fallback.

I get a

Ignoring BGRT: Invalidstatus 0 (unexpected 1)

everytime I try to live boot/reinstall ubuntu

USB/DVD boot doesn't matter it does not get past BGRT error message. can't get into tty

heres my componenets in hopes of someone having similar setup that they may have some knoweldge as to either fix my issue and get back all of gnome and ubuntu things, or find out why the USB/DVD wont get past BGRT .

i7 5820k
G1 980TI
16GB Kingston Hyper X Predator 3GHz

4TH HGST (windows Storage)
2TB Hitachi(windows Storage)
1TB WD (8GB swap | 923GB /home )


120gb OCZ vertex 3 (51GB Linux Games EXT4 | 60GB Windows Games NTFS)
Corsair Neutron XT 240 ( Ubuntu 60GB /boot | Windows 10 boot )

Honestly, just switch distros.

Ubuntu has a nasty habit of breaking when you do a large upgrade.

Try opensuse tumbleweed. Its a pretty damn stable rolling release distro, and it just got gnome 3.20.

at this point I just need to be able to install something to get my data off, then I can start fresh. Not even a live cd will work, I'll try tumbleweed to see if I can get live boot to work with that

Can you tell us what Kernel you were running before everything exploded?

The BGRT (ACPI Boot Graphics Resource Table) [1.] issue you see should be a non-fatal issue.
It's occurring because the status value in the table is zero, hence bit 0 (the display bit) is not turned on, so the boot graphic is not being displayed.
If your system is locking up/halting here you may need to try a Distro with a newer kernel that handles this error correctly. Or just try an older Kernel and see if you can atleast get a session going.

Then just backup your data and reinstall a distro of your choice and see if it happens again or not.

1. ACPI 6.0 documentation

Wait, not even a live CD will work?

Whats goes wrong with like a live ubuntu dvd? Are there any error codes?

1 Like

If you want to I can help you move to Arch. I've had the least issues with my Arch box compared to Linux Mint. Linux Mint is great and I enjoyed it very much; I just had some weird graphics glitches during boot up that I couldn't fix. Arch has its quirks, but the simplicity of it makes it very easy to fix package related issues.

The only serious issues I've had was a libcroco update breaking custom themes, (There was a fix in a few days, and I just had to rollback the package) and not being able to get my 360 controller to stop flashing on the -ck kernel. (trying to figure out how to install that package right now)

For any system I'd suggest installing rsnapshot, and backing up to another disk. It has made restoring corrupted files, and quickly fixing broken systems so easy.

well its deffintely something wrong with the system or something, because now the openSUSE installation and live boot hangs with the repeated text box

shet, um I think it was 3.18.XXXXXXXX

I was running Ubuntu With GNOME 14.04 trusty tahr

I was honestly just trying to fix the screen tearing issue on youtube videos with the update...

Error code is the"[ 0.039666] Ignoring BGRT: unexpected status 0 (expected 1)
honestly the numbers in the front change all the time though

would I be safe with deleting the Linux boot partition from windows? Do you think the old kernal see's my install as an upgrade attempt and halts because its attempting to feed data that is simply not there or broken?

This is what happens when I apt-get install ubuntu-desktop

Hmmm. Are you booting openSuse tumbleweed? That's using the 4.0.4 Kernel and should be fine.

But if even a live disk doesn't work correctly there's something weird going on with your Hardware settings.
It honestly doesn't matter what's on you hard disk, you could unplug your hard disk and a livedisk will boot fine. The livedisk doesn't touch HDD's.

Issues I can image are:

  1. A Kernel ACPI Bug with your mainboard or Firmware version. (Have you updated your Firmware recently?)
  2. Something strange is going on with UEFI Boot (Unlikely but I have seen wonky EFI tables do some really weird shit.)
  3. Magic XD

Possible actions:

  1. reset your BIOS settings to some limited defaults and see if you can boot.
  2. Boot some ancient non-UEFI LiveDisk in old-school BIOS mode and see where you can get
  3. Last resort (If possible we want to avoid this) Update your BIOS

Wait... So it does boot?
What if you try this

I assume u want the ubuntu desktop?
sudo aptitude install ubuntu-desktop

the orignal ubuntu session boots, but hangs in a seemingly endless cycle of samba windbind starting ..until it finally stops, then thats all it does. I left it over night I know thats where it stops.


from there I can CTRL + ALT + F1-4 into tty login.

There I've tried update,upgrade, install ubuntu-desktop, install gnome-shell, install -f, upgrade --fix-missing. nothing seems to work.

but when I do get to the tty and try install ubuntu-desktop. I get that fantastical effort from the system to do nothing in the end.

aptitude is missing as some core libs are missing as well. so that's a bust for me too. that was like the 2nd thing I tried. hah

Ok in that case your apt package database is surely broken.

First can you post the output of this command (So i can see if there conflicting repositories)

[One Line]
cat /etc/apt/sources.list; for X in /etc/apt/sources.list.d/*; do echo; echo; echo "** $X:"; echo; cat $X; done

Don't run the following yet until I have seen that output:

Log into a tty and get to superuser
sudo su
next wipe temporary packages
apt-get autoclean && apt-get autoremove

Rebuild package database:
dpkg --configure -a
apt-get update
apt-get -f install

If that succeeds you can retry to install gnome destop
apt-get install ubuntu-gnome-desktop

I cant really just copy and past and thats about all I can see as well

Well it all looks to be ok. And you should be able to run the cleanup commands fine.
If even that fails, honestly, just reinstall it will take less time to fix.
I can't see the ubuntu default repo's but I assume they just got cut-off on the output. You can prepend:
more |
to that command it will allow you to scroll through the entire output with spacebar.

Well it looked like there were none of the ubuntu ppa's so I finally got OpenSUSE to install in nomodeset, then I installed it, mounted the partitions and drives correctly. make a / and a /bootefi fat partition, now if I run it like normal, the neaveaufb drives fails and freezes, even when in runlevel 3. I'm getting ready to give up on this.

its now stuck at [2.001660] fb: switching to nouveaufb from EFI VGA
it cant get a tty as its frozen there. Tried runlevel 3 and runlevel 5. its stiull frozen.