Return to Level1Techs.com

Level1 Techs HDMI KVM - losing display after screen turns off?

Currently using my HDMI KVM to connect to some spare TV I have until I get a proper PC monitor. The TV is an Insignia NS-24L120A13, which typicalyl defaults to 1080p 60Hz. This TV has no option to stay awake indefinitely, and turns off after about an hour without use.

Currently I have two Linux and one Windows machines plugged in through the KVM. The Linux machines work perfectly fine, but the Windows one has issues with working again after this the screen turns off after an hour without use.

The actual issue is that afterturnign the TV screen back on, no amount of moving the mouse or using the keyboard will restore the display of the Windows machine. I tried unplugging & replugging the KB & mouse, but to no avail. The only fix is for me to hold button on the back of the KVM for 10 seconds to rescan for the EDID again, then switch to another input on the KVM, then back to the Windows machine’s input.

Is there no way to prevent this from happening? My next best bet is to replace this TV with a proper PC monitor that has proper EDID settings and the ability to control the timeout for automatically turning being turn off, but I’m hoping there’s at least a temporary workaround for the time being.

Press and hold the edid button for 20 seconds instead of 5 and see if that makes a difference. There may be a way to tell windows to avoid deep sleep.

1 Like

I’ll try holding the button for 20s next time it happens. Funny thing is, I did set Windows to never go to sleep, yet this TV monitor doesn’t respect this setting whatsoever. I guess that’s to be expected from a 10+ year old cheap TV model.

Also OMG it’s the one and only Wendell!

Figured out a solution, tl;dr Windows 10 settings are very dumb.
Before I fixed the issue, I made sure that I set the screen and the PC not to turn off in Control Panel -> Hardware & Sound -> Power Options -> Change Plan settings for my current power plan. I also even copied an AutoHotKey script I made for work that registers a mouse movement every 3 minutes to keep the PC on, but neither of these worked.

Then I went and searched “power options” in the Windows 10 search bar and it led me to the Windows 10 Settings app, where it had it’s own “Turn Screen Off after X minutes” option, which was not to what I set it in the regular Control Panel. Changed it to “never” and now it’s all good!